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Chapter 1 Introduction

E-ASR is used to collect answers to pre-designed questionnaires. These answers are then merged with
a report template and a standard report is generated. The merging process allows the user to insert
different
responses and paragraphs into the report depending upon how a question is answered.

The program comes with questionnaires and report templates for the following:

· ASTM E1527-21 Phase I Environmental Site Assessment
· ASTM E1902-19 Phase II Environmental Site Assessment
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1.1 Features

Some of the features of E-ASR are:

· Reports can be generated to follow any standard, including ASTM and CSA.

· Reports can be used for Phase I ESAs, Phase II ESAs, Environmental Compliance, Transaction

Screening, etc.

· In addition to your answers to the questionnaire, photos (ex. site, aerial, historic) and third-party

reports (ex. EDR, EPA, NPRI) can also be integrated into the final report.

· The data can be collected on a tabloids, laptops, or desktops.

· A blank paper form to collect the data for a questionnaire can be created with the press of a button.

· The answers to questions are tracked, and a list of unanswered questions can be displayed at any

time.

· Report templates are created and edited in Microsoft Word.

· There can be an unlimited number of questionnaires.

· Questionnaires can contain an unlimited number of questions.

· Questions can contain sub-questions and be branched based upon the answer to the question.

· The program comes with numerous predefined question types and additional custom question types

can be created.

· Text macros can be created and used to rapidly enter common text answers; such as, asbestos

materials, drainage, site descriptions, storage tank contents, etc.

· Merged report can be immediately opened in Word.

· Microsoft Access database management system.

· Master project database tracks projects over a network.

· Supports either stand-alone or network licensing.

· Users are assigned a username, password, and privilege level.

· Different privilege levels allow for control of who can edit questionnaires.

· Questionnaires, macros, and projects can be imported from Pocket ESA.
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1.2 Methodology and Data Flow

E-ASR has been designed to minimize the amount of time required to generate a standard report and to
maximize the flexibility of the final report. To accomplish this, the process has been divided into four
steps. The first two steps only need to be performed once for each type of questionnaire and report. The
last two steps are performed for each report. 

1 Create a Report Template

The first step is to create a report template using Microsoft Word. This template is later merged with the
specific responses to create a final report. The template is a generic form of the final report and contains
keywords where the specific responses
to the questionnaire are to be merged into the report. These keywords are highlighted in the report
template using a unique style created for the E-ASR+ program.

The responses to be merged into the report are not necessarily the direct answers to the questions, but
are the text responses associated with the answer. For example, if the answer to the question “Are there
any ACMs suspected?” is “No” the text
merged into the final report is not necessarily “No” but could be a paragraph of text that has been
associated with this answer; such as, “There are no asbestos containing materials suspected on the
subject property.” These associations are defined as part of the questionnaire and are entered during the
creation of the questionnaire.

2 Create a Questionnaire

The next step is to create a questionnaire that is used to collect the response data for a report.
Typically, the questionnaire will adhere to a national standard such as the CSA or ASTM standards.
However, abbreviated questionnaires may be created and used in some situations.

Questionnaires are divided into sections and subsections which can contain any number of questions.
For every question a question type is selected. The question type determines the format of the question
and allowable answers that are used to collect the data. There are numerous question types that can be
selected and additional question types can be created. After the question type has been selected and
the question entered, the text associated with each allowable answer is entered. This is the text that will
actually be merged into the final report.
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When the questionnaire is created it is associated with a report template that is used to create the
merged report. Each question is associated with a keyword from the report template. These keywords
are used as placeholders in the final report for the text associated with the question response.
Depending upon the length of the report and number of questions, these first two steps can be very labor
intensive. But after they have been completed, the resulting questionnaires can be used to generate
thousands of reports.

3 Enter Questionnaire Responses

After the questionnaire has been created, it can be used to collect the responses for a report. The
response data is collected by answering each of the questions in the questionnaire. The form used and
allowable answers for the question are specified when the questionnaire is created. All of the data is
automatically saved as it is entered. After the data has been collected it is merged with the report
template to create a final report. Prior to merging the data with the report template, the answers can be
modified and edited.

4 Merge Questionnaire Responses with the Report Template

The final step is to create a report by merging the questionnaire responses with the report template.
During the merging process the keywords in the report template are replaced by the text associated with
each of the answers to the questions. After the survey data has been merged a final report will be
created in Microsoft Word format. This report can then be edited in Word to include additional
information.
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1.3 Installation

To get E-ASR up and running, the program first needs to be installed on your computer. The program can
be downloaded from GAEA's website. There are two types of installation, single user and network user.
The installation section below will explain how to perform both types of installations.

1.3.1 Single User Installation

Installation

When installing the program you must be logged in as an administrator.

The following steps occur during the installation:

· The application is installed on your computer
· Files for the databases and data store are copied to your computer
· Shortcuts are placed on your Start menu and desktop

After the application has been installed, there are a few more steps before it is ready for use. The
datastore needs to be setup, a default basemap selected, and example projects can be imported. All
these steps are accomplished by running E-ASR for the first time. The program can be started using the
icon on your desktop or the E-ASR application menu on the Start menu. 

First-Run and Program Setup

The first time that the program is run you must be logged in as an administrator so that the
directories can be created.

When the program is started for the first time a setup wizard will run that guides you through the steps
below.

1. Selection of a single user or network user installation.
2. Select the industry that you will be using to register the software. The price, features, and settings in

the application will change depending on the industry selected.
3. After the above information is specified the databases and data store will be setup.
4. The next step is to specify a default basemap for the application.  
5. And the last step is to import any demo projects to help learn the application faster.

After the above steps are completed, the application will start initially in demo mode. You can use the
application in demo mode for up to 20 times before you need to register  it. 

Directory Permissions

The data for the application is stored in the database and data store directories. The location of these
directories will depend on the operating system and is defaulted to the common application data
directory. All of the users must have full read and write access to these directories. When
possible the installation program will try to set the permissions of these directories properly.
 For administrative users this will not be a problem; however, limited users may need to be given
permission to read and write to these directories. The location and method of setting the permissions will
vary with the type of Windows operating system as described below.

Windows XP Home

20
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The default directory where the database and datastore directories are located for Windows XP is "c:
\Documents and Settings\All Users\Application Data\AutoReporting2". Typically non-administrative
(limited) users may only have read access to this directory. To change the permissions on this directory
to grant limited users full control follow the steps below.

1. Log in as an administrator
2. In Windows Explorer browse to the directory "c:\Documents and Settings\All Users\Application Data"

and highlight the folder "AutoReporting2".
3. Right click on the AutoReporting2 folder and select "Sharing and Security" from the popup menu, the

form below will be displayed.
4. On the Sharing tab check the boxes for "Share this folder on the network" and "Allow network users

to change my files".

Windows Vista and XP Professional

The default location for the database and data store files in Windows Vista is "c:
\Users\Public\Application Data\AutoReporting2". Typically non-administrative (limited) users only have
read access to this directory. To change the permissions on this directory to grant limited users full
control follow the steps below.

1. Log in as an administrator
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2. In Windows Explorer browse to the directory "c:\Users\Public\Application Data" and highlight the
folder "AutoReporting2".

3. Right click on the AutoReporting2 folder and select "Properties" from the popup menu, the form below
will be displayed.

4. On the Security tab make sure that the group "Everyone" has "Full Control" permissions.

Windows 8 and above

The default location for the database and data store files is "c:\ProgramData\GAEA\AutoReporting2".
Typically non-administrative (limited) users may only have read access to this directory. To change the
permissions on this directory to grant limited users full control follow the steps below.

5. Log in as an administrator
6. In Windows Explorer browse to the directory "c:\ProgramData" and highlight the folder

"AutoReporting2".
7. Right click on the AutoReporting2 folder and select "Properties" from the popup menu, the form below

will be displayed.
8. On the Security tab make sure that the group "Everyone" has "Full Control" permissions.
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1.3.2 Network Installation

The installation of the network version of the application on the server and client computers is described
in the section Network License Management .214
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1.4 Registration

E-ASR can be licensed on individual computers, a network, or a combination of both. When licensed on
a network the licensing is based on concurrent usage, where the number of concurrent users must be
less than or equal to the maximum number of users licensed. When the application it will run in demo
mode until it is licensed. 

The method for licensing will depend upon whether it is a single user or network installation. The
registration sections below discuss how to license E-ASR and how to transfer the registration if
necessary.

1.4.1 Single User Registration

To license E-ASR, a registration code must be entered. The registration code is based on the serial
number. This serial number is unique for each computer.

The serial number can be obtained by running the program and selecting the Tools > Manage Licenses.
The License Manager form will be displayed with a table that shows the current licensing. To get detailed
information click on the program in the table. The detailed information will be displayed to the right. 

1.4.1.1 Manual Entry of Registration Codes

To manually obtain the serial number and enter the registration code for E-ASR, select it in the License
Manager table and then click on the Register button on the toolbar at the top of the Manage Licenses
form. The Register form will then be displayed showing the unique serial number of the module. 
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To obtain the registration code enter the invoice number you received when purchasing the software and
contact GAEA with the unique serial number. GAEA can be contacted either by clicking on the Obtain
Registration button or be emailing us at codes@gaeatech.com. When the Obtain Registration button is
used an email form will be displayed where you can enter your contact information and email it directly to
GAEA.

After you receive the registration code from GAEA you can enter it on the Register form and then save it
by clicking on the Store Code button.

1.4.1.2 File Entry of Registration Codes

The serial number can be exported to a file and emailed to GAEA. After the file has been processed a
registration file will be emailed back from GAEA. This registration file can then be imported and the
registration code saved. To export the serial number file, select E-ASR on the License Manager form and
then click on the Export button on the toolbar of the form. The Export Serial Number form will be
displayed where you can enter the invoice number and your contact details. After you enter the
information you can either email the file directly to GAEA by clicking on the Email button or save it to
your disk and email it yourself by clicking on the Save button.

mailto:codes@gaeatech.com.
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After the file has been received and processed by GAEA you will receive a registration file back by email.
When you receive this file save it to your hard drive. To import the file click on the Import button on the
License Manager form and the Import Registration Code form will be displayed. Select the file you saved
using the Open button on the form and the registration codes will be imported and saved by the program.
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1.4.2 Network Registration

Prior to using the application on the client computers, the application should be registered on the server.
The registration on the server is handled through the Network Monitor program and is described in the
section on Using the Network License Manager . 

1.4.3 Transferring the Registration

If you need to transfer the license for a single user installation from one computer to another, follow the
steps below.

On the licensed computer

· select the Manage Licenses menu item from the Tools menu
· select the module that you wish to transfer the license on the License Manager form
· either click on the Relock button on the toolbar at the top of the form or select Relock from the popup

menu
· the Relock below form will be displayed 

217



Environmental - ASR24

© 2023 GAEA Technologies Ltd.

All of the information on this form needs to be filled in, including the file name. After the information is
entered click on the Relock button to email the relock file to GAEA. After the button is clicked the
Relock code will be displayed and the module will no longer be licensed on this computer.

On the new computer

After you have sent GAEA the relock file follow the instructions for single user registration  described
above.

16
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1.5 Using the Application

Login

All users must login to the application. When users are setup in the application they are assigned a
username, password, and user type (privilege). Different privilege levels are used to control access to
functions of the program and data. The different user types are administrator, power user, limited user,
and guest. For more information on setting up users see User Administration .

To have the application remember your user name and password, check remember credentials. The next
time the application is started you will not need to enter your login credentials. If you are using the
network to login, the Network Settings button can be used to change the network properties.

Initial Display

The initial display will consist of a Geographical Information System (GIS) or a list of projects depending
on your settings in Preferences. The GIS shows your existing projects and any GIS data. To the left of
the GIS the sidebar usually shows a list of your projects. And to the right of the GIS the sidebar usually
shows a list of layers, scale, and an index map. At the top of the display there are also toolbars and
menus for controlling and using the program. These are described briefly below and in detail in the
chapters throughout this manual.
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Menus

The main menu appears at the top of the screen and is composed of several submenus for Files, Tools,
and Help. Depending upon what is open at the time, an Edit submenu may also be present. The File
submenu is used  to create, open, and delete projects, questionnaires, and report templates; import and
export data; and set program preferences. Several types of tools are included in the Tools submenu for
the geodatabase, projects, macors, question types, and managing the program licenses.

In this User's Guide menu items and paths have been abbreviated to make it easier to understand. All
menu items are shown in blue italics and start with the uppermost menu then an arrow to the next menu
or menu item. For example, the Project menu item of the Open submenu of the File menu is abbreviated
as File > Open > Project.

A popup menu can also be displayed by clicking the right mouse button, the menu items in the popup
menu will vary depending on what is being displayed and where on the screen the mouse is clicked. In
this manual menu items that can be obtained from the popup menu are shown as Popup > menu item.

Toolbars

Initially two toolbars will be displayed, a Main toolbar and a GIS toolbar.

The Main toolbar is used to create, open, and close projects, questionnaires, and report templates. If a
project is open you can also create and open report responses and reports. In addition it can be used to
display different views, the help guide and exit the program.
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The GIS toolbar is used to access various features and functionality of the GIS. This toolbar is described
in the GIS section .

Sidebars

The sidebars can be on the left, right, or both sides and contain the contents described below.

Projects

The projects region has a Find Project toolbar and a list of projects. You can locate a project in the list
using the Find toolbar by entering the project name and pressing the Find button. The project will then be
highlighted in the project list and be zoomed to in the GIS. You can also zoom to a project in the project
list by selecting the Popup > Locate after the project has been highlighted in the list. 

To open a project using the Project List, highlight the project and then select Popup > Open or double-
click on it in the sidebar. If no project is selected, the Open Project form will be displayed. This form lists
the projects and lets you select one to open. 

For a detailed description of how to create and use projects see the section below and Chapter 3 .

Layers

The layers region lists the layers in the GIS. These layers can be turned on and off by checking and
unchecking the box beside the layer. The order of the layers in the sidebar controls the order in which
they are displayed in the GIS, with the layers at the top being drawn on the layers at the bottom.

Scale Bar

The scale bar displays the current scale of the GIS or project shown in the GIS window.

North Direction

The compass on the bottom right shows the current direction for North. When the application is started
this is at the top of the screen. To change the direction slide the bar to the left or right below the
compass. Sliding to the left will rotate the GIS windows to the West, sliding to the right will rotate to the
East. Double-click on the slider to adjust the display so that North is at the top of the screen again.

1.5.1 Geographic Information System

The Geographical Information System (GIS) is used to organize, find, and select projects. The
application can also be used with no GIS, in this case a list of projects is displayed instead. When the
GIS is being displayed it obtains its geographical data from a Web Map Service.

The display of the GIS and default Web Map Service is specified in the Preferences .
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1.5.1.1 Web Map Services

Web map services use a standard protocol to serve georeferenced map images over the Internet. This
protocol was developed and published by the Open Geospatial Consortium. Several web map services
are available within the application and more are being added with each update. 

1.5.1.1.1  Selecting Web Map Services

The web map service displayed for the GIS can either be selected from the GIS toolbar or in File >
Preferences. If it is selected in Preferences it will be the default web map service and will be shown every
time the application is started. When it is selected from the GIS toolbar it will be effective only until it is
changed again or the application is closed.  New web map services are being added all the time. If you
would like to have a web map service added that is not in the list please contact us.

Before displaying the web map service the application checks to see if there is an Internet connection. If
there is no connection a list of projects will be displayed.

1.5.1.1.2  Adding a Web Map Service

Additional custom web map services (WMS) can be added to the application by selecting Tools > GIS >
Add Web Map Service. The form below will then be displayed. A custom web map service can be used
to add user subscribed services such as First Base Solutions ( a Canadian based service for high
resolution orthoimagery).

The following information can be specified on this form:

Name: This is the name of the custom WMS. It will be displayed when selecting a WMS from the GIS
toolbar.

URL: This is the URL for the custom WMS. The URL is usually specified by the service provider.

Copyright: This the copyright for the custom WMS. It will be displayed on the status bar at the bottom
of the screen.
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1.5.1.2 Using the GIS

The display of the GIS can be controlled using the GIS toolbar and compass control as described in the
sections below. The use of the GIS to create and locate projects is described in the Chapter 3.

1.5.1.2.1  GIS Toolbar

The GIS toolbar can be used to adjust the basemap display; find, identify and select features.The
controls on this toolbar depend on whether the basemap is a static basemap or web map service.

Full Extent

The Full Extent button will display the full extent of the GIS or project

Zoom In

The Zoom In button is used to zoom in to a smaller scale on the GIS. 

Zoom-out

The Zoom Out button is used to zoom out to a larger scale on the GIS. 

Dynamic Zoom

The Dynamic Zoom button can be used to zoom in and out using the mouse. 

To zoom in 
1. Click on the View/Zoom mode menu item.
2. Within the Map area choose a rectangular area to which you would like to zoom in.
3. Move the mouse pointer to the top left corner of the area and press the left mouse button.
4. Move the mouse pointer to the bottom right corner of the area and release the left mouse button.

To zoom out 
1. Click on the View/Zoom mode menu item.
2. Within the Map area decide how large should be the area containing the currently visible extent and where it should be located after zooming out.
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3. Move the mouse pointer to the bottom right corner of this area and press the left mouse button.
4. Move the mouse pointer to the top left corner of this area and release the left mouse button.

Drag

The Drag button is used to move the visible area on the screen. To move the visible area click on the
screen and while holding the mouse button down move the cursor in the desired direction to see that
area displayed.

Select Feature

The Select Feature button can be used to select a feature on the map. To select a feature click on the
button and then click on the feature on the map. The attributes of the selected feature will then be
displayed as shown below.

Display Hints

The Display Hints button can be used to select the layer and field used for hints. These hints can
optionally be displayed when the mouse is over a feature on the map. For example, when the mouse if
over a project the hint could display the project name. When the button is pressed the Map Hint
Properties form below will be displayed. This form can be used to specify whether hints are shown, the
hint color, layer and field to use for the hint.
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Search

The Search button can be used to search for features on the map that meet a specified criteria. When
this button is pressed the Search form below will be displayed. This form can be used to specify the
layer, field. and search criteria. When the Search button on this form is pressed any features that meet
this criteria will be momentarily highlighted.

Web Map Service

This drop down list can be used to select the current web map service being displayed. 

North Arrow
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The North arrow on the GIS can be turned on and off using the North Arrow button. The color of this arrow
is specified in Preferences .

Find Address

Addresses can be located on the GIS by clicking on the Find Address button. The form below will be
displayed and can be used to find addresses by street address, latitude and longitude, or UTM
coordinated.

Find Address at a Point

The address of a point on the GIS can be displayed using the find address at a point button. After this
button is clicked, click on the point on the GIS and the address will be displayed.

Find Elevation at a Point

The elevation of a point on the GIS can be displayed using the find elevation at a point button. After this
button is clicked, click on the point on the GIS and the elevation will be displayed.

Measure Distance
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Distances can be measured on the GIS using the Measure tool on the GIS toolbar. When this tool is
selected the Ruler control below will be displayed. The distance units can be set using the drop down list
on the right. To measure a distance click on the first point and then click on the second. To hide the
Ruler control click on the Measure tool again.

Street View

A street view for a point on the GIS can be obtained by clicking on the down arrow of the Street View
button and selected either Google or Bing. Then click on the point on the map to display the street view
in the Street View form. Additional street views can be displayed by closing the form and clicking on
other points on the map. The street view form for Google and Bing are explained in the sections below.

Save Image

This is used to save the map image either to the project or to a file. When saving to the project, the
document name and version are specified. The images in a project can later be used in project views.
When saving to a file the file name is specified.

The street view form for Google is shown below. The Google street view image is 640 x 640 pixels.
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The following can be specified on this form:

Heading: This is the heading from North of the image. When the heading is changed the image will be
refreshed.

Pitch: This is the vertical pitch on the image. Positive values are up and negative values are down. 
When the pitch is changed the image will be refreshed.

Field of View: This is the field of view of the image, similar to the zoom.  When the field of view is
changed the image will be refreshed.

Save to Project: This is used to save the image in the project. This option is only available when a
project is opened. When this button is clicked on the name of the Document (Image) and Version can be
specified. The images in a project can be later used in project views.

Save to File: This is used to save the image to a JPEG file. When this button is clicked the file name
can be specified.
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The street view form for Bing is shown. The Bing street view is 350 x 350 pixels.

The following can be specified on this form:

Heading: This is the heading from North of the image. When the heading is changed the image will be
refreshed.

Pitch: This is the vertical pitch on the image. Positive values are up and negative values are down. 
When the pitch is changed the image will be refreshed.
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Zoom: This is the zoom of the image.  When the zoom is changed the image will be refreshed.

Save to Project: This is used to save the image in the project. This option is only available when a
project is opened. When this button is clicked on the name of the Document (Image) and Version can be
specified.The images in a project can be later used in project views.

Save to File: This is used to save the image to a JPEG file. When this button is clicked the file name
can be specified.

1.5.1.2.2  Compass Control

The compass on the bottom right shows the current direction for North. When the application is started
this is at the top of the screen. To change the direction (heading) slide the bar to the left or right below
the compass.

1.5.1.3 Spatial Queries

Spatial queries can be used to find projects that meet specified criteria.

1.5.1.3.1  Querying Projects

Spatial queries can be used to select projects based on their location and other selection parameters. To
spatially query projects, select Tools > GIS > Spatial Queries > Projects. The Query Area form below
will be displayed.

This form is used to specify whether the query will be based on a Selected Region or the Full Extent of
the map. 
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If the query is based on a Selected Region, the region needs to be selected after the Ok button is
pressed. To select the region, click the mouse button at one corner of the region and then move the
mouse to the opposite region while holding down the button. After the region has been specified or the
Full Extent selected the Query Projects form will be displayed.

This form is used to specify the selection queries to be used to select the projects. More than one query
can be used for the query, the queries to be used are shown on the left side of the form. For a project to
be selected it must meet all of the queries. 

To select additional queries use the Select Query combobox on the form. These queries can be based
on areal extent, client ID, client, project name, project ID, date created, or status. When an additional
query is selected, the parameters for the query can be specified beneath the combobox. After the
parameters of the query have been specified the query can be added to the list by pressing the Add
Query button. After a query has been added to the list it can be removed by selecting it on the list and
pressing the Remove Query button.

To conduct the query, press the Perform Query button at the top of the form.  The results of the query
will be display on a Results tab. This tab will list the projects that meet the query. 

A project from the list can be opened by selecting and then pressing the Open button. In addition, the list
can be exported to an Excel file by pressing the Export button. 
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1.5.2 No GIS

If no GIS is specified in Preferences the main window will display a list of projects as shown below.  A
project can be opened by double-clicking it in the list or by highlighting it and selecting Popup > Open. 
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1.6 Preferences

To set the program preferences no project can be open. Select File > Preferences. The Preferences form
will be displayed. This form has a list of preference categories on the left side and the details of the
selected category are displayed on the left. Each of the categories are described in the sections below.
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1.6.1 Appearances

The following can be edited in the Appearances category:

User Interface

Display new object prompts: Check this box to display prompts for new objects.

Open last project: Check this box to open the last opened project when the program is started.

Activate undo: Check this box to activate the undo feature so that some operations can be undone.

Status bar: Check this box to display a status bar on the main form.

Maximize form: Check this box to maximize some forms when they are displayed.

Show toolbar button text: Check this to show the text on buttons.

Projects
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Show Project Boundary: Check this box to show the project boundary when a project is opened.

Margin: This is used to specify the margin between the project display and the project boundary as a
percentage of the display width. The larger the margin the larger the area outside of the project boundary
will be displayed.

Line Style: Click this button to change the line style, width, and color of the boundary line.

Look up new project addresses: Check this box to look up the project address when a new project is
created using the GIS.

1.6.2 Automated Reporting

The following can be edited in the Automated Reporting category:

Merge Information

Style Name: This is the name of the style in Word to use for the merging process.
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Speed: This is used to select the speed of the merge from fast to slow. Merging uses the Windows
clipboard and if done too fast may miss some substitutions. If a fast merge misses some substitutions
try setting it to average or slow.

Table Defaults

Font: This is the font name to use for text in tables.

Font Size: This the font size to use for text in tables.

Font Color: This the font color to use for text in tables.

Bold Fixed: Check this to use bold fonts in fixed rows and columns in the tables.

Exceedence Color: This the color to use for the background of cells with exceedences. The
exceedence is determined by setting a criteria column or row in the table definition  of the question
form.

Bold Exceedence: Check this to use bold fonts for exceedences.

Appendix Defaults

Appendix Name: This is the keyword name for the questionnaire appendix in the report template. If this
keyword is found in the report template the questionnaire results (without merging) will be inserted.

Font: This is the font name to use for text in the questionnaire output.

Font Size: This the font size to use for text in the questionnaire output.

Font Color: This the font color to use for text in the questionnaire output.

Default Question Form Size

Width: This is the default width for the question forms.

Height: This is the default height for the question forms.

Question Response Form

Tabbed: Check this to show the Question Response form  with two tabs, one for the response and
one for the report preview.

Not Tabbed: Check this to show the Question Response form with the response on the left and the
report preview on the right.
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1.6.3 Backups

The following can be edited in the Backups category:

Main Database

Back Up: If this checkbox is checked then the main databases will be backed up at regular intervals. If
this checkbox is not selected then the main databases will not be backed up.

Interval: This is used to select the interval to use when backing up the main databases.

Number to maintain: This is the number of backups to maintain, older backups will be deleted.

Project Databases

Back Up: If this checkbox is checked then the currently open project will be backed up at regular
intervals. If this checkbox is not selected then the currently open project will not be backed up.

Interval: This is used to select the interval to use when backing up the project database.

Number to maintain: This is the number of backups to maintain, older backups will be deleted.
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Backup on Project Close: Check this to create a backup of the project when it is clsed.

1.6.4 Company

Company information is used in different parts of the application for addressing emails, etc. The following
can be edited in the Company category:

Company Name: This is your company name. 

Contact Name: This is the contact name to use in correspondence from the application.

Phone Number: This is the phone number for the company.

Fax Number: This is the fax number for the company.

Email: This is the main email address for the company.
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Street 1: This is the first line of the street address.

Street 2: This is the second line of the street address.

City: The is the city for the company.

State: This is the state or province for the company.

Country: This is the country for the company.

Postal Code: This is the postal or zip code for the company.

1.6.5 Datasources

The following can be edited in the Datasources category (these features should not be changed without
consulting your database administrator):

User name: This is the user name for the main database. Normally, it should be Admin.
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Password: This is the password for the main database. Normally, it is blank.

Path: This is the path to the main database.

Test Connection: Click this button to test if the main database exists.

Datastore folder: This is the folder containing the datastore.

Show Folder: Click this button to show the datastore folder.

1.6.6 Defaults

The following can be edited in the Defaults category:

Location Precision: This is the precision (number of decimal places) to use when displaying location
information.
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Decimal Degree Precision: This is the precision (number of decimal places) to use when displaying
decimal degrees. 

Default Local Units: This is used to select whether to use feet or meters for the default local units.

Most Recent: This is used to set the number of most recent objects to show.

1.6.7 GIS

The following can be edited in the GIS category:

Basemap
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Type: Select the type of basemap to use for the default. The type of basemap can be a web map service
or none. 
 
Default Basemap: This is the basemap to use for a web map service. 

Initial Display

This is used to select the initial display when the application is started. It can either show an area around
where you are located, an area showing the extent of all of your projects, or a previously set basemap
extent.

GIS Display

Show GIS Sidebar: Check to show the GIS sidebar.

Show Compass: Check to show the GIS compass.

Display Units: This is used to select the units for the current cursor location shown in the status bar at
the bottom of the display.

Map Scale

Number of Dividers: This is the number of dividers in the scale bar.

Divider Color 1: Click this button to change the color of the first divider in the scale bar.

Divider Color 2: Click this button to change the color of the second divider in the scale bar.
 
North Arrow

Color: Click this button to change the color of the North arrow on the map.
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1.6.8 Internet

The following can be specified for the Internet category:

Outgoing Email Settings

Outgoing email settings are used to send emails for technical support.

Host: This is the name of the host for outgoing emails.

Port: This is the port to use for outgoing emails.

Username: This is the username to use for outgoing emails.

Password: This is the password to use for outgoing emails.

Use TLS/SSL: Check this to use TLS or SSL for outgoing emails.

Test Settings: Click this button to test the outgoing email settings.
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1.6.9 Maintenance

The following can be edited in the Maintenance category:

Application Updates

Check for updates: Check this box to automatically check for program updates on the Internet.

Schedule: Select the schedule to check for program updates.

Application Maintenance

Perform maintenance tasks: This is used to select whether to perform maintenance tasks.

Delete expired cache objects: Check this box to delete cache images of objects when maintenance is
performed.
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Check for unassociated projects: Check this box to find and delete projects that are in the project
database but not in the project list.

Schedule Tasks: Select the schedule to perform maintenance.

Perform every: If the schedule is custom, this is used to specify the number of days between
maintenance tasks.

Run now: Click this button to run maintenance tasks now.

1.6.10 Network License

The following can be edited in the Network License category (these features should not be changed
without consulting your database administrator):

Networked:  This is used to indicate whether the program and licensing is running from a central
database and server.

Network Settings
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Name or IP Address: This is the name or IP address of the server. If the program is not networked it will
be "localhost".

Port Number: This is the port number for the server. If the program is not networked it will be disabled. It
should be set to 3001.

Request network licenses for: This is the program and modules to request licenses from the server.

Clear auto-login: Click this button to clear the auto-login file. The next time you login you will be
required to enter a username and password.
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1.7 Macros

During the data collection process for report responses some of the text being entered will be repetitive
or best selected from a list of text. In order to reduce the time required to enter repetitive text, text
macros can be used. Text macros are composed of lines of text (up to 255 characters) that can be
selected and inserted for responses. To make it easier to select the text, the macros are divided into
sections. 

1.7.1 Editing Macros

To add or edit a text macro select Tools > Macros > Edit and the Edit Macros form will be displayed 

The text macros are divided into sections to make it easier to organize and select the text. Sections are
displayed on the left side of the form and the text for the selected section is
displayed on the right side.

Sections

· To add a new section click on the Add button above the sections and then enter the name of the
section.

· To delete a section select the section and then click on the Delete button above the section.
· To open an existing section click on the section. The text macros for that section will then be

displayed on the right part of the form.
· To rename a section select the section and then double click on the name.
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Text Macros

· To add a new text macro to a section, make sure that the section is open and then click on the Add
button above the text macros. Then enter the text for the macro.

· To delete a text macro from a section, make sure that the section is open . Then select the text to be
deleted and then click on the Delete button above the text macros.

· To change the text for a text macro select the text and then double click on the text.

1.7.2 Exporting Macros

Test macros can be exported to an XML exchange file that can be imported on to other computers
running E-ASR by selecting Tools > Macros > Export.The Export Macro form will be displayed and can
be used  to specify the export file.

1.7.3 Importing Macros

Text macros previously exported to an XML exchange file can be imported by selecting Tools > Macros
> Import. The Import Macros form will be displayed and can be used to select the XML exchange file.
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1.7.4 Importing Pocket ESA Macros

Macros that have been exported from Pocket ESA can be imported by selecting File > Import > Pocket
ESA Macros. The Import Pocket ESA Macros form will be displayed and the macro file with the
extension ".mcb" can be selected. 
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1.8 Help and Support

GAEA Technologies strives to make this application easy to use and learn. Several tools and features
are provided to assist the user to learn the program and when necessary get technical support. These
features can be found in the Help menu of the main menu and are described below.

1.8.1 Help System

In addition to the User's Guide in PDF format, context sensitive help can be found within the application.
The help system can be displayed by either selecting Help > Contents or clicking on the Help button on
a form. When the Help button on a form is used, the help displayed will be specific to that specific form.

1.8.2 Tutorials

Numerous online tutorial videos are available to assist you in learning the program. These tutorials can
be accessed by selecting Help > Online Tutorials or going to the web page:

https://www.gaea.ca/tutorial_videos.php

1.8.3 Technical Support

Customers with a current technical maintenance agreement can receive technical support by selecting
Help > Email Technical Support. This is the preferred method of obtaining technical support since it
provides us wit the maximum amount of information and data concerning your problem. Before emailing
technical support you will need to provide the outgoing email settings in preferences  for the email to
be sent by the application.
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The following is displayed and/or edited on this form:

Company: This is your company or organization name that has the license for the program.

Name:  This is your name.

Email: This is your email address.

Phone: This is your phone number.

Operating System: This is Windows operating system of the computer. It is automatically filled in by
the application and can not be changed.

Modules: This is a list of the modules, versions, licenses, and networking for the application. It is filled in
automatically by the application and can not be changed.

Main Database: Check this to attach the main database for the application. It include project
boundaries, templates and project documents. It is highly recommended that this database is included in
your email. 

Project Database: If a project is opened, this will be displayed. Check this to include the project
database with your email. If your problem involves project specific data (boreholes, cross-sections,
samples, etc.) please include this database.

Error: This is brief description of the error that will be shown in the subject of the email.

Description: This is a detailed description of the error or problem. Please provide as much information
as possible.
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1.8.4 Updates

Updates to the program are periodically published online and can be installed by selecting Help > Check
for Updates. If an update is available from the Internet, you will be asked whether to install it or not. We
strongly recommend you install all updates.
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Chapter 2 Report Templates

Prior to creating a questionnaire a report template using Microsoft Word should be created. This report
template is later merged with the specific responses of a questionnaire to create a final report. The report
template is a generic form of the final report and contains keywords where the specific answers to the
questionnaire are to be merged into the report. These keywords are highlighted in the report template
using a unique style created for the program.

The answers to be merged into the report are not necessarily the direct answers to the questions, but
are the text responses associated with the answer. For example, if the answer to the question “Are there
any ACMs suspected?” is “No” the text
merged into the final report is not necessarily “No” but could be a paragraph of text that has been
associated with this response; such as, “There are no asbestos containing materials suspected on the
subject property.” This response can be further edited prior to being merged. These associations are
defined as part of the questionnaire and are entered during the creation of the questionnaire.

The easiest method to create a report template is to edit a copy of an existing report in Word. This
edited report template can then be imported  as described below. In addition, a new blank report
template can be created  as described below.
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2.1 Creating a Report Template

To create a new blank report template select File > New > Report Template when no project is open. The
New Report Template form will be displayed showing the current report templates.

Enter the new report template name (description) then press the Ok button. The new report template will
be displayed in Word. 
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2.2 Opening a Report Template

A  report template can be opened when no project is open by selecting File > Open > Report Template.
The Open Report Template form will be displayed. 

Select the report template to open and then press Ok to open it in Microsoft Word.
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2.3 Editing a Report Template

A style for the E-ASR keywords can be added to the report template and used to highlight the keywords.
These keywords should replace the text in the report that will change for each questionnaire response.
Proper placement of the keywords and the text to be substituted requires planning and some trial and
error experience. Before editing a report template it is recommended that the example report templates
included with the program be reviewed.

2.3.1 Adding a Style to a Word Document

The name of the style used to highlight the keywords in the report template is specified in
Preferences . The name of the style specified in E-ASR must exactly match the name used in the
report template. Before entering the keywords in the report template the style should be added to the
Word Document if it does not already exist. There are two types of styles in Word, paragraph and
character. The E-ASR style must be a character style.

To add the E-ASR character style to the report template, open the report template in Word and then
select the Create a Style from the Style bar. Enter the name of the style as “E-ASR” or whatever name
was specified in the preferences. In the Style type box select Character then change any other format
options desired such as font style and color. To make it easier to recognize the keywords in the report
template it is recommended that the style have a different color and font.
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2.3.2 Using Styles in a Word Document

After the E-ASR style has been added to the report template, it can be used to highlight the keywords.
To change the style of a keyword select the keyword and then either select the E-ASR style from the
Style bar.
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2.4 Deleting a Report Template

To delete a report template select File > Delete > Report Template when no project is open. The Delete
Report Template form will be displayed showing the current report templates. Select the report template
to delete and press the Delete button.
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2.5 Importing a Report Template

To import a new report template select File > Import > Report Template when no project is open. The
Import Report Template form will be displayed showing the current report templates.

Specify a name (description) and select the file containing the report template, then press Ok to import
the report template.
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Chapter 3 Questionnaires

After the report template has been created the next step is to create a questionnaire that is used to
collect the responses for a report. This questionnaire will assign a keyword specified in the report
template to each question. The text associated with the answer to that question will then replace the
keyword when the questionnaire and report template are merged to create a final report.

Questionnaires are divided into sections and subsections which can contain any number of questions.
For every question a question type is selected. The question type determines the format of the question
and allowable answers that are used to collect the response data. There are numerous question types
that can be selected and additional question types can be created.  After the question type has been
selected and the question entered, the text associated with each allowable answer is entered. This is the
text that will actually be merged into the final report.
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3.1 Creating and Editing Question Types

Every question in a questionnaire has a question type that determines the format of the question and
allowable answers that are used to collect the response data. The application comes with numerous
predefined question types and additional ones can be created. Each question type consists of a form
with several controls used for collecting data for the question. 

Question types can be either template or non-template. Template question types can be used to create
other question types and questionnaires. Whereas, non-template question types can only be used to
create questionnaires. The question type can be set as a template or non-template when editing the
question type.

3.1.1 Creating a Question Type

To create a new question type select Tools > Question Types > New. The New Question Type form will
be displayed.

This form is used to specify the unique name for the question type and a template to be used for the
question type. A list of existing question types is displayed on the Existing tab. If no template is
selected a blank form is used. When a template is highlighted a preview of the template is shown on the
right. After the Ok button is pressed the question type will be created and can be edited as described
below .70
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3.1.2 Opening a Question Type

To open an existing question type for editing select Tools > Question Types > Open. The Open Question
Type form will be displayed. 

This form displays a list of template and non-template question types. Only question types that can be
opened and edited will be displayed. Some question types are required to import Pocket ESA data and
can not be edited.

When a question type is highlighted a preview of the form will be displayed on the right. After the
question type has been selected it will be opened for editing as described below .

3.1.3 Editing a Question Type

After a question type has been created or edited the Question Type Editor from will be displayed. This
form has a sidebar on the left showing information on the currently selected control. If it is a new
question type there will only be a question label on the preview. Every question type should have a
question label that will be replaced by the question when creating a questionnaire. This question label
must have the Name "Question".
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At the top of the form there are toolbars for the adding, aligning, copying, and deleting controls, adjusting
the view, setting the tab order, and saving the question type as described in the sections below.

If no control is selected the following form properties can be entered on the sidebar:

Width: This is the width of the form.

Height: This is the height of the form.

Template: If this is set to true, the question type can also be used as a template.
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3.1.3.1 Adding and Editing Labels

 

Labels are used to show text information for the question and do not collect any data. To add a label,
click on the Add Label button and then click on the preview where you want the label to be placed. Or to
edit an existing control click on it.

After a label has been added or selected for editing, the control properties will be shown on the left
sidebar. The following properties can be edited:

Name: This the unique name of the control. The name cannot contain any spaces. If it is the question
label, the name must be "Question".

Caption: This is the text to display for the label. If it is the question label, the question entered in the
questionnaire will be substituted for the text.
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Width: This is the width of the label in pixels.

Height: This is the height of the label in pixels.

Left: This is the left position of the label in pixels from the left edge.

Top: The is the top position of the label in pixels from the top edge.

Justification:  This is used to select the justification for the label.

3.1.3.2 Adding and Editing Edit Boxes

 This is used to add an edit box. Edit boxes are used to enter one line of text for the question type.
To add an edit box, click on the Add Edit Box button and then click on the preview where you want the
edit box to be placed. Or to to edit an existing control click it.
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After an edit box has been added or selected for editing, the control properties will be shown on the left
sidebar. The following properties can be edited:

Name: This the unique name of the control.  The name cannot contain any spaces.

Caption: This is the text to display for the caption of the edit box.

Width: This is the width of the control in pixels.

Height: This is the height of the control in pixels.

Left: This is the left position of the control in pixels from the left edge.

Top: The is the top position of the control in pixels from the top edge.

Label Position: This is used to select position of the caption relative to the edit box.

Edit Type:  This is used to select the type of data that can be entered. It can either be a string, a
floating point number, or an integer.

3.1.3.3 Adding and Editing Up-Down Edit Boxes

 This is used to add an edit box with an up-down arrows. These edit boxes are used to enter
numeric data and the up and down arrows are used to increment and decrement the numeric data. To
add an up-down edit box, click on the Add Up-Down Edit Box button and then click on the preview where
you want the control to be placed. Or to to edit an existing control click it.



Chapter 3 Questionnaires 75

© 2023 GAEA Technologies Ltd.

After an up-down edit box has been added or selected for editing, the control properties will be shown on
the left sidebar. The following properties can be edited:

Name: This the unique name of the control.  The name cannot contain any spaces.

Caption: This is the text to display for the caption of the up-down edit box. 

Width: This is the width of the control in pixels.

Height: This is the height of the control in pixels.

Left: This is the left position of the control in pixels from the left edge.

Top: The is the top position of the control in pixels from the top edge.

Label Position: This is used to select position of the caption relative to the control.
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3.1.3.4 Adding and Editing a Memo Entry

 This is used to add a memo. Memos are used to enter several lines of text for the question type.
To add a memo, click on the Add Memo button and then click on the preview where you want the control
to be placed. Or to to edit an existing control click it.

After the control has been added or selected for editing, the control properties will be shown on the left
sidebar. The following properties can be edited:

Name: This the unique name of the control.  The name cannot contain any spaces.

Width: This is the width of the control in pixels.

Height: This is the height of the control in pixels.

Left: This is the left position of the control in pixels from the left edge.

Top: The is the top position of the control in pixels from the top edge.
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3.1.3.5 Adding and Editing a Combo Box

 This is used to add a combo box. Combo boxes are used to select text from a drop-down list. To
add a combo box, click on the Add Combo Box button and then click on the preview where you want the
control to be placed. Or to to edit an existing control click it.

After a combo box has been added or selected for editing, the control properties will be shown on the left
sidebar. The following properties can be edited:

Name: This the unique name of the control.  The name cannot contain any spaces.

Caption: This is the text to display for the caption of the control. 

Width: This is the width of the control in pixels.

Height: This is the height of the control in pixels.

Left: This is the left position of the control in pixels from the left edge.

Top: The is the top position of the control in pixels from the top edge.
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Label Position: This is used to select position of the caption relative to the control.

Items: This is used to select the items displayed in the combo box. The items are selected from the
macro sections. Prior to setting up the question type a macro section  should be added for the combo
box.

3.1.3.6 Adding and Editing a Date Picker

 This is used to add a date picker. Date Pickers are used to select a date for the question type. To
add a date picker, click on the Add Date Picker button and then click on the preview where you want the
control to be placed. Or to to edit an existing control click it.

After the control has been added or selected for editing, the control properties will be shown on the left
sidebar. The following properties can be edited:
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Name: This the unique name of the control.  The name cannot contain any spaces.

Caption: This is the text to display for the caption of the control. 

Width: This is the width of the control in pixels.

Height: This is the height of the control in pixels.

Left: This is the left position of the control in pixels from the left edge.

Top: The is the top position of the control in pixels from the top edge.

Label Position: This is used to select position of the caption relative to the control.

3.1.3.7 Adding and Editing a List Box

 This is used to add a list box. List boxes are used to select text from a list. To add a list box, click
on the Add List Box button and then click on the preview where you want the control to be placed. Or to
to edit an existing control click it.
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After a list box has been added or selected for editing, the control properties will be shown on the left
sidebar. The following properties can be edited:

Name: This the unique name of the control.  The name cannot contain any spaces.

Width: This is the width of the control in pixels.

Height: This is the height of the control in pixels.

Left: This is the left position of the control in pixels from the left edge.

Top: The is the top position of the control in pixels from the top edge.

Items: This is used to select the items displayed in the list box. The items are selected from the macro
sections. Prior to setting up the question type a macro section  should be added for the list box.

If a caption is desired for the list box, it can be added as a label in a separate control.

3.1.3.8 Adding and Editing a Checkbox

 This is used to add a checkbox. Checkboxes are used to select one or more items. Checkbox
controls can not be added if the question type already contains radio button group controls.

To add a checkbox, click on the Add Checkbox button and then click on the preview where you want the
control to be placed. Or to to edit an existing control click it.
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After a checkbox has been added or selected for editing, the control properties will be shown on the left
sidebar. The following properties can be edited:

Name: This the unique name of the control.  The name cannot contain any spaces.

Caption: This is the text to display for the caption of the control. 

Width: This is the width of the control in pixels.

Height: This is the height of the control in pixels.

Left: This is the left position of the control in pixels from the left edge.

Top: The is the top position of the control in pixels from the top edge.

Justification:  This is used to select the justification for the label.

Checked: This is used to set the default checked state of the control.
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3.1.3.9 Adding and Editing a Radio Button

 This is used to add a radio button. Radio buttons are used  to select one item from several
items.Unlike checkboxes only one radio button can be selected at a time. To add a radio button, click on
the Add Radio Button button and then click on the preview where you want the control to be placed. Or
to to edit an existing control click it.

After a radio button has been added or selected for editing, the control properties will be shown on the
left sidebar. The following properties can be edited:

Name: This the unique name of the control.  The name cannot contain any spaces.

Caption: This is the text to display for the caption of the control. 

Width: This is the width of the control in pixels.

Height: This is the height of the control in pixels.

Left: This is the left position of the control in pixels from the left edge.

Top: The is the top position of the control in pixels from the top edge.
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Justification:  This is used to select the justification for the label.

Checked: This is used to set the default checked state of the control.

3.1.3.10 Adding and Editing a Radio Button Group

 This is used to add a radio button group. Radio button groups can be used to select one item from
each group. Radio button groups can not be added if the question type already contains checkbox
controls.

To add a radio button group, click on the Add Radio Button button and then click on the preview where
you want the control to be placed. Or to to edit an existing control click it.

After a radio button group has been added or selected for editing, the control properties will be shown on
the left sidebar. The following properties can be edited:
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Name: This the unique name of the control.  The name cannot contain any spaces.

Caption: This is the text to display for the caption of the control. 

Width: This is the width of the control in pixels.

Height: This is the height of the control in pixels.

Left: This is the left position of the control in pixels from the left edge.

Top: The is the top position of the control in pixels from the top edge.

Columns:  This is the number of columns of items in the group.

Items: This is used to set the items in the group. When this is clicked on a list is displayed that can be
used to add and edit the items.

3.1.3.11 Adding and Editing a Checkbox List

This is used to add a list of check boxes. Checkbox lists can be used to select one or more items
from a list. The list of selected items can then be displayed in the report.

To add a checkbox list, click on the Add Checkbox List button and then click on the preview where you
want the control to be placed. Or to to edit an existing control click it.
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After a checkbox list has been added or selected for editing, the control properties will be shown on the
left sidebar. The following properties can be edited:

Name: This the unique name of the control.  The name cannot contain any spaces.

Width: This is the width of the control in pixels.

Height: This is the height of the control in pixels.

Left: This is the left position of the control in pixels from the left edge.

Top: The is the top position of the control in pixels from the top edge.

Format:  This is used to select how the list of selected items is displayed in the report. The selected
items can be displayed with bullets, numbers, or just the item name (none)..

Items: This is used to set the items in the list. When this is clicked on a list is displayed that can be
used to add and edit the items.
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3.1.3.12 Adding and Editing a Table

 This is used to add a table. Tables are used to enter table data in columns and rows. To add a
table, click on the Add Table button and then click on the preview where you want the control to be
placed. Or to to edit an existing control click it.
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After a table has been added or selected for editing, the control properties will be shown on the left
sidebar. The following properties can be edited:

Name: This the unique name of the control.  The name cannot contain any spaces.

Width: This is the width of the control in pixels.

Height: This is the height of the control in pixels.

Left: This is the left position of the control in pixels from the left edge.

Top: The is the top position of the control in pixels from the top edge.

Fixed Column:  This is used to select whether there is a fixed column at the top of the table.

Fixed Row:  This is used to select whether there is a fixed row at the left of the table.

Fixed Color: This is used  to select the background color of the fixed column or row.

Border: This is used to select the line style for the border of the table. The border line for the table will
be a solid single line in the response preview, but will be shown as selected in the merged Word report. 

Column Count:  This is used to specify the number of columns in the table.

Row Count:  This is used to specify the number of rows in the table.

Columns: This is used to specify the columns in the table. When this property is clicked the columns
form is displayed. 

Rows: This is used to specify the row headings in the table if there is a fixed column. When this property
is clicked the rows form is displayed..

Criteria: This is used to specify if there are any criteria being entered in the table. When this property is
clicked the criteria form is displayed.

Units: This is used to specify if there are any units being entered in the table. When this property is
clicked the units form is displayed.
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3.1.3.12.1  Editing Table Columns

For each column in the table the following can be specified:

Header: This is used to specify the text for the fixed row at the top of the column. If there is no fixed row
in the table this field will not be shown.

Width: This is the relative width in pixels. The width of the first column will be automatically adjusted to
take up the remaining table width based on the other column widths.

Alignment: This is used to select the horizontal alignment of text in the column.

Right Line: This is used to select the line style for the right side of the column. The column line for the
table will be a solid single line in the response preview, but will be shown as selected in the merged
Word report. The right line style for the last column can not be selected since it represents a border for
the table.

Edit Type: This is used to select the type of information that can be entered in the column (String, Date,
Time, Float, Integer, or Combo List). 

Combo Items: If the Edit Type is Combo List the type combo items can be selected. The combo items
are the macro sections  previously specified. When entering information in the response for the table
the text can be selected from the text macros in the macro section.
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3.1.3.12.2  Editing Table Row s

For each row in the table the following can be specified:

Header: This is used to specify the text for the fixed column at the left of the table. If there is no fixed
column in the table this field will not be shown.

Bottom Line: This is used to select the line style for the bottom side of the row. The row line for the
table will be a solid single line in the response preview, but will be shown as selected in the merged
Word report. The bottom line style for the last row can not be selected since it represents a border for
the table.

3.1.3.12.3  Editing Table Criteria
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A row or column can be used to specify numerical criteria for the table. In subsequent rows or columns
any numerical value greater than the criteria is considered an exceedence and will be displayed with a
different background color and/or bold font . 

The following can be specified on this form:

Specify Criteria: Check this box to specify criteria for the table.

Row or Column: Select whether the criteria is in a row or a column.

Row/Column: This is used to specify which row or column will contain the criteria.

3.1.3.12.4  Editing Table Units

A row or column can be used to specify units for the table. When the table is being completed as part of
a response, the first units specified in either the units row or column will be automatically entered for the
remaining rows or columns making data entry quicker and easier. 

The following can be specified on this form:

Specify Units: Check this box to specify units for the table.

Row or Column: Select whether the units is in a row or a column.

Row/Column: This is used to specify which row or column will contain the units.

3.1.3.13 Adding and Editing a Table Control

 This is used to add a table control. Table controls are used to control the number of rows or
columns in a table. To add a table control, click on the Add Table button and then click on the preview
where you want the control to be placed. Or to to edit an existing control click it.
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After a table control has been added or selected for editing, the control properties will be shown on the
left sidebar. The following properties can be edited:

Name: This the unique name of the control.  The name cannot contain any spaces.

Caption: This is the text to display for the caption of the control.

Width: This is the width of the control in pixels.

Height: This is the height of the control in pixels.

Left: This is the left position of the control in pixels from the left edge.

Top: The is the top position of the control in pixels from the top edge.

Label Position: This is used to select position of the caption relative to the edit box.

Table to Control:  This is used to select the table  to control.

Control Type:  This is used to select whether to control the number of rows or columns in the table.
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3.1.3.14 Aligning Controls

These buttons are used to align two or more controls as follows:

 This is used to align the left sides of the selected controls.

 This is used to align the right sides of the selected controls.

 This is used to align the centers of the selected controls.

 This is used to align the tops of the selected controls.

 This is used to align the bottoms of the selected controls.

 This is used to align the middles of the selected controls.

3.1.3.15 Spacing Controls

These buttons are used to space two or more controls as follows:

 This is used to space the selected controls evenly horizontally.

 This is used to space the selected controls evenly vertically.

3.1.3.16 Copying a Control

 This is used to copy a control. After selecting a control, click this button to place a duplicate of the
control underneath it.

3.1.3.17 Deleting a Control

 This is used to delete the selected control.

3.1.3.18 Changing the Grid

 This is used to select the grid spacing of the form. There can either be a 4x4, 8x8, or no grid.

3.1.3.19 Setting the Tab Order

 This is used to specify the tab order of the controls. The tab order is used to specify which control is
moved to when the tab is pressed when entering the data for the question. When this button is pressed
the Edit Tab Order form is displayed and the order of the controls can be adjusted using the up down
arrows.
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3.1.3.20 Saving the Question Type

 This button is used to save the question type.

3.1.4 Deleting a Question Type

To delete a question type, select Tools > Question Types > Delete. The Delete Question Type form will
be displayed. Select the question type to delete then press the Ok button.
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3.1.5 Exporting a Question Type

To export a question type to an XML exchange file select Tools > Question Types > Export. The Select
Question Type form will be displayed. Select the question type to export then press the Ok button.
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3.1.6 Importing a Question Type

To import a question type from an XML exchange file, select Tools > Question Types > Import. The
Import Question Type form will be displayed where the XML exchange file can be selected.
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3.2 Creating and Editing Questionnaires

Typically, a questionnaire will adhere to a national standard such as the CSA or ASTM standards.
However, abbreviated questionnaires may be created and used in some situations. After a questionnaire
has been created it can be used to generate numerous reports. 

3.2.1 Creating a Questionnaire

To create a new questionnaire either click on the New button then select Questionnaire or select File >
New > Questionnaire when no project is opened. The New Questionnaire form below will be displayed.

The following information can be entered on this form:

Name: This is the unique name of the questionnaire. To see a list of existing questionnaires click on the
Existing tab.

Standard: This is the standard used for the questionnaire. Such as, CSA or ASTM.
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Report Template: Select the report template from the list.

After the above information has been entered press the Ok button to create the questionnaire. Once the
questionnaire has been created the sections, sub-sections, and questions can be created and edited as
described in the sections below.

3.2.2 Opening a Questionnaire

To open an existing questionnaire either click on the Open button then select Questionnaire or select
File > Open > Questionnaire when no project is opened. The Open Questionnaire form below will be
displayed.. Select the desired questionnaire and press the Open button.

3.2.3 Editing a Questionnaire

After a questionnaire has been created or opened it will be displayed as shown below. A tree view will be
displayed showing the sections, subsections, and questions specified in the questionnaire. 
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Sections in the tree view can be expanded and collapsed by double clicking on the section name. When
the section is collapsed only the section is displayed and the subsections are hidden. When the section
is expanded all of the subsections are displayed below the section. Subsections can contain one or
more questions and can be expanded or collapsed by double clicking on the subsection name. When
the subsection is collapsed only the subsection is displayed and the questions are hidden. When the
subsection is expanded all of the questions are displayed below the subsection. The sections  and
subsections  can be edited as described in the sections below.

Questions can also contain sub-questions that can be shown be clicking beside the question. A
question can be edited by double-clicking on the question or highlighting the question then selecting Edit
from the popup menu. The editing of a question is described in the Editing Questions  section below.

At the top of the questionnaire form there are buttons for the following:

  This button is used to edit the general information  for the questionnaire.

  This button is used to find text  within the questions.

  This button is used to add a section . The button will only be enabled when the top node
showing the questionnaire name in the tree is selected. The section will be added at the bottom of the
sections.

  This button is used to add a subsection . The button will only be enabled when a section is
selected. The subsection will be added at the bottom of the section.

   This button is used to add a question . The button will only be enabled when a subsection or
question is selected. If a subsection is selected the question will be added at the button of the
subsection. If a question is selected the new question will be added as a sub-question.
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  This button is used to edit the selected section , subsection , or question . The button is
only enabled when a section, subsection, or question is selected.

 This button is used to copy a question . This button is only enabled when a question is
selected.

  This button is used to paste a question  that has been previously copied/ This button is only
enabled when a question has been copied.

    This button is used to delete a section , subsection , or question .

   This button is used to check the keyword usage .

  This button is used to refresh the keywords from the report template. This can be used after the
report template has been edited and saved to refresh the list of keywords available to be assigned to the
report section  of a question.

   This button is used to open the report template in Microsoft Word.

    This button is used to create a blank questionnaire form .

  This button is used to save the questionnaire.

  This button is used to save the questionnaire with a different name .

   This button is used to close the questionnaire.

3.2.3.1 Editing General Information

 

The general information for the questionnaire can be edited using the Edit General Information button or
selecting Edit > General.  The General Information form will then be displayed. This form is used to
specify the standard and report template used for the questionnaire.
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3.2.3.2 Editing Sections

The sections of a questionnaire contain all of the subsections and are indented once from the left. A
questionnaire can have any number of sections. The sections can be edited as described below.

 Adding a Section

To add a new section select the questionnaire name at the top of all the sections, then either click on
the Add Section button on the toolbar or select Edit > Add Section.  A new section will be created at the
bottom of the questionnaire with the name New Section. The name of the section can be changed by
entering it in the input box. 

 Renaming a Section

The name of a section can be changed by double-clicking on the section or by highlighting the section
and then clicking on the edit button on the toolbar or selecting the Edit > Edit. The new name of the
section can then be entered in the input box.

 Moving a Section

Sections can be moved up or down by selecting the section and then clicking on the up or down arrows
on the toolbar.
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 Deleting a Section

To delete a section, select the section and then click on the Delete button on the toolbar or Edit >
Delete. When a section is deleted all of the subsections and questions within the section will also be
deleted.

3.2.3.3 Editing Subsections

Subsections of a questionnaire contain all of the questions and are members of a section. A section can
have any number of subsections. The subsections can be edited as described below.

 Adding a Subsection

To add a new subsection select the section, then either click on the Add Subsection button on the
toolbar or select Edit > Add Subsection.  A new subsection will be created at the bottom of the current
section with the name New
Subsection. The name of the subsection can be changed by entering it in the input box. 

 Renaming a Subsection

The name of a subsection can be changed by double-clicking on the subsection or by highlighting the
subsection and then clicking on the edit button on the toolbar or selecting the Edit > Edit. The new name
of the subsection can then be entered in the input box.

 Moving a Subsection

Subsections can be moved up or down by selecting the subsection and then clicking on the up or down
arrows on the toolbar.

 Deleting a Subsection

To delete a subsection, select the subsection and then click on the Delete button on the toolbar or Edit
> Delete. When a subsection is deleted all of the questions within the subsection will also be deleted.

3.2.3.4 Editing Questions

The questions of a questionnaire are grouped into subsections. A subsection can have any number of
questions. 

  Adding a Question

To add a new question select the subsection or question, then either click on the Add Question button
on the toolbar or select Edit > Add Question. The button will only be enabled when a subsection or
question is selected. If a subsection is selected the question will be added at the button of the
subsection. If a question is selected the new question will be added as a sub-question. A new question
will be created with the name New Question. The name of the question is the text from the question itself
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and will be changed when the new question is edited. After the question has been added it will be
opened for editing .

 Editing a Question

A question can be edited by clicking on the Edit button on the toolbar. The button is only enabled when a
section, subsection, or question is selected. The editing of a question is described in the section
below.

 Copying a Question

A question can be copied by selecting it and clicking on the Copy button. It can then be pasted into the
questionnaire using the Paste button. This button is only enabled when a question is selected.

 Pasting a Question

After a question has been copied, it can be pasted into the questionnaire using the Paste button. This
button is only enabled when a question has been copied.

 Moving a Question

Questions can be moved up or down by selecting the question and then clicking on the up or down
arrows on the toolbar. Questions can also be sub-questions of a question by moving them to the right
using the right arrow on the toolbar. If a question is a sub-question it can be moved to the left using the
left arrow and will no longer be a sub-question.

 Deleting a Question

To delete a question, select the question and then click on the Delete button on the toolbar or Edit >
Delete. 

3.2.3.4.1  Editing a Question

To edit a question double click on the question. The question can then be edited in the Question form
shown below. This form has two tabs, one for the question and one for the report. The question  tab is
used to specify the question type and question and the report  tab is used to specify the text that will
be inserted into the report during the merging of the report responses and report template.
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Section Replacement

At the top of the form is a checkbox for Section Replacement. If the box is checked, during the merging
of the report any instance of the section heading (keyword) will be replaced with the answer text. If the
box is not checked, during the merging of the report the answer text will only be inserted below the first
instance of the keyword and the section heading (keyword) will be left in place.

Report Section

At the top of the form there is a combo box where you can select the keyword in the Report Section.
When the arrow on the right is selected a list of keywords that have been entered in the report template
will be displayed. A keyword from the list must be selected for the question. This keyword will determine
where the text results of the question will be placed in the report when it is merged. If no keyword is
selected the results of the question will not appear in the report.

Question Selection

At the bottom of the form there are buttons that can be used for the following:

 Moves to the first question (short cut key is Home)
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 Moves to the previous question (short cut key is Page Up)

  Moves to the next question (short cut key is Page Down)

  Moves to the last question (short cut key is End)

 

The question tab is used to specify the question type and question.

The following can be specified on this tab:

Question Type: The question type determines the format of the question and the types of answers that
are allowed. To select the question type click on the arrow to the right of the input box. The question
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type can then be selected from the list of question types. The Preview button on the right can be used to
display a preview of the question type. If the question type is multiple choice, input boxes will be added
to the bottom of the tab for the possible choices. Enter the text for each of the choices in these input
boxes.

Preview: Press the preview button to see a preview image of the question type.

Question: This is the text that is displayed on the Questionnaire form and on the Question form when
entering report responses.

Multiple Choice: For multiple choice question types this is used to specify the choice names.

The response tab is where you select a response for the question and enter the text associated with the
selected response. 

The following can be specified on this tab:
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Report Response: This is used to select a response from a list of responses. The available responses
will depend on the type of question. For example, for a Yes/No question there would be two available
responses or for a Multiple Choice 3 Response question type there would be 3 responses.

Next Question: If the question type has radio buttons, a radio button group, or checkboxes and there
are sub-questions to this question, this is used to select which sub-question to go next when this
response is selected.

Insert: The Insert button allows for the insertion of text that was entered when the question was
answered. For example, this text could be entered as the “Description” or as “Additional Information” for
the question. When the Insert button is pressed a list will be displayed showing the types of text that
could be entered with the question. This list will depend on the question type. To include the text entered
for the associated text of the question, position the cursor in the text input box where you want the
inserted text to appear and then click on the Insert button and select it from the list.

Text Input Box: Below the response selection is a Rich Text toolbar and input box, these are used to
enter the text associated with the selected response. The text associated with the response can be as
simple or as complicated as desired. There is no practical limit to the length of the text. When creating
bulleted or numbered text at least one line of normal text must be inserted first.

3.2.3.5 Organizing Questions

In addition to being organized under sections and subsections, questions can also be sub-questions of a
question. Sub-questions can be used to select which question will follow the answer for a branched
question. Branched questions include radio buttons or checkboxes. The number of branches depends on
the number of radio buttons or checkboxes. The assignment for the next question in a branch is
specified on the Response  tab. 

For example, if the question has a yes or no answer, one sub-question can be assigned for a yes answer
and another sub-question can be assigned for the no answer.

Another example would be a multiple choice question using checkboxes where each sub-question is
used to specify the information for each selected checkbox.

106
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Sub-questions can also have sub-questions, this can be used when there are multiple sub-questions for
one branch. 

Below is an example used in the ASTM Phase II ESA questionnaire. In this example, if test pits were
excavated a list of tests pits is specified and then additional questions are asked about the test pits.

3.2.3.6 Finding Text

 

Text within questions can be located using the Find button or selecting Edit > Find.  The Search form will
then be displayed. 
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The following can be specified on this form:

Text to find: This is used to specify the text to search for.

Report section: Check this box to search for the text in the report section of questions.

Question: Check this box to search for the text in the question part of questions.

Case sensitive: Check this box to make the search case sensitive.

Whole words only: Check this box to limit the search to whole words only.

After the text and options have been specified, press the Find button to display the results of the search.
The questions containing the specified text will be listed in the table. A question in the table can be
opened by double-clicking on it in t he table.

3.2.3.7 Checking Keyword Usage

  

When designing a questionnaire it can be helpful to know what report sections (keywords) in the report
template have not been used and what questions have not been assigned a report section (keyword). To
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display a list of unused keywords and unassigned questions, click on the Check Keywords button on the
toolbar or select Edit > Check Keyword Usage.

3.2.3.8 Creating a Blank Questionnaire Form

 

The questionnaire can be used to create a blank form that can be used to collect the data remotely by
clicking the Create Blank Questionnaire Form button on the toolbar or selecting Edit > Create Blank
Questionnaire. The Create Blank Questionnaire form will be displayed.
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The following can be specified on this form:

Numbering: Select whether to number each question in the questionnaire.

Line Spacing: Select whether the questions should be single or double-spaced.

Table Width: This is used to specify the width of the tables in either inches or millimeters.

Blank Form Name: This is used to specify the file name for the blank form.

3.2.3.9 Copying a Questionnaire

To copy the questionnaire save it as a new questionnaire with a different name by clicking on the SaveAs
button. The Save Questionnaire As form below will be displayed, where you can enter the unique name,
standard and select the report template of the new copied questionnaire. To make it easier to specify a
unique name a list of existing questionnaire is displayed on the Existing tab.
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3.2.4 Deleting a Questionnaire

A questionnaire can be deleted by selecting File > Delete > Questionnaire when no questionnaire is
open. The Delete Questionnaire form will be displayed where the questionnaire can be selected and then
deleted by pressing the Delete button.
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3.2.5 Exporting a Questionnaire

To export a questionnaire to an XML exchange file, open the questionnaire then select File > Export >
Questionnaire. The Export Questionnaire form will be displayed and is used to specify the name of the
export file.
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3.2.6 Importing a Questionnaire

Questionnaires that have been previously exported to XML exchange files, can be imported by selecting
File > Import > Questionnaire when no project is open. The Import Questionnaire form will be displayed
and is used to select the XML exchange file.
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3.2.7 Importing a Pocket ESA Questionnaire

Prior to importing any Pocket ESA projects, the Pocket ESA questionnaires used by the projects should
be imported.

Questionnaires that have been exported from Pocket ESA can be imported by selecting File > Import >
Pocket ESA Questionnaire. An Import Pocket ESA Questionnaire file dialog form will be displayed to
select the questionnaire file to import. The exported Pocket ESA questionnaires are comprised of two
files with the ".qtn" and ".rpt" extensions. Select the ".qtn" file in the dialog form. 
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Chapter 4 Projects

Projects are the primary building block of E-ASR and are used to encapsulate all the data in the
application. The sections below describe how to manage projects, import data into projects, and export
data from projects.
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4.1 Project Management

The initial display of E-ASR will consist of a basemap (or project list) and sidebars on the left and right.
The basemap shows your existing projects and any GIS data contained in the web map service. To the
left of the basemap, the sidebar usually shows a list of your projects. And  the right sidebar usually
shows a list of layers in the basemap and an index map. Prior to use projects must either be created or
imported. After this they can be selected from the basemap or sidebar and edited. 

On the project tree sidebar, projects can be grouped into categories and subcategories. These groupings
can be used to sort projects by things such as year, office, and client. The creation and editing of these
categories and subcategories is described in the section on editing project categories  below. In
addition, the most recently opened projects are grouped at the top of the project tree.

Projects can be assigned to a category or subcategory when they are created  or edited.

4.1.1 Creating a Project

There are two types of projects, georeferenced or local. Georeferenced projects have GIS based
coordinates, normally in decimal degrees, and can be seen on basemaps.Whereas, local projects have
coordinates in feet or meters and are not shown on basemaps.

Georeferenced Project

If the project is to be georeferenced, the area of the basemap where the project is located should be
zoomed in on first before creating the project. To assign the project to a category or subcategory on the
project tree, highlight the category or subcategory first and then create the project. To create a new
georeferenced project either select File > New > Project > Georeferenced or click the New button on the
main toolbar and select Project > Georeferenced. 

After this you will need to specify the boundaries of the project on the basemap. To do this click the left
mouse button at each of the points on the project boundary, then double click or right click when done.
Projects can be square or polygonal. The New Project form will then be displayed. This form has five tabs
for a georeferenced project as described in the sections below. 

Local Project

To create a new local project either select File > New > Project > Local or click the New button on the
main toolbar and select Project > Local.  The New Project form will then be displayed. This form has four
tabs for a local project as described in the sections below. 

138
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4.1.1.1 Project Info Tab

The following information can be specified on this tab:

Project Number: This is the unique project number.

Project Name: This is the name of the project.

Set Password: Check this box to set a password for the project.

Password: If Set Password is checked the password can be specified, 

Client ID: This is an optional client identification.

Client Name: This an optional client name.
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Address: This is the street address of the project.

City: This is the city of the project.

State/Province: This is the state or province of the project.

Country: This  is the country of the project.

Postal/ZIP Code: This is the postal or ZIP code of the project.

4.1.1.2 Boundary Tab

This tab is shown for georeferenced projects only and used to specify the georeferenced boundary
points.
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The default coordinate system for georeferenced projects is the WGS 84 geographic system. Alternate
geographic or projected coordinate systems can be selected; however, the coordinates stored in the
database will be in the default system.

Coordinate System

Geographic System: Select this to specify the boundary in geographic coordinates.

Projected System: Select this to specify the boundary in projected coordinates.

Coordinate System: This is used to select the geographic or projected coordinate system.

Degrees Minutes Seconds: If the selected coordinate system is geographic, select this to specify the
coordinates as degrees, minutes, and seconds.

Decimal Degrees: If the selected coordinate system is geographic, select this to specify the
coordinates in decimal degrees.

Boundary Points

Longitude: If it is a geographic coordinate system, this is the longitude of the boundary point in either
decimal degrees or degrees, minutes, and seconds.

Latitude: If it is a geographic coordinate system, this is the latitude of the boundary point in either
decimal degrees or degrees, minutes, and seconds.

X Coordinates: If it is a projected coordinate system, this is the x coordinate of the boundary point.

Y Coordinates: If it is a projected coordinate system, this is the y coordinate of the boundary point.

Add Point: Press this button to add a point to the boundary.

Delete Point: Press this button to delete the selected boundary point.

4.1.1.3 Local Coordinates Tab

The information on the local coordinates tab will depend on whether it is a local or georeferenced project.

4.1.1.3.1  Georeferenced

If the project is a georeferenced project the map coordinates will be in decimal degrees. For display in 3D
local coordinates in either feet or meters will need to be assigned. Changing the local coordinates for a
project after it has been created is not advisable using this tab, since only project coordinates will be
changed and not the borehole or well coordinates. If it is necessary to change the coordinates after
boreholes or wells have been created the Assign Local Coordinates  function should be used. 137
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The following information can be specified on this tab:

Local Units: Select either feet or meters.

Reference Corner: Select the corner of the project to use as a reference. The x and y coordinates
below will be assigned to this corner.

X Coordinate to Corner: This is the x coordinate of the reference corner.

Y Coordinate to Corner: This is the y coordinate of the reference corner.

4.1.1.3.2  Local

If the project is a local project the coordinates will be either feet or meters. Changing the local
coordinates for a project after it has been created is not advisable using this tab, since only project
coordinates will be changed and not the borehole or well coordinates. If it is necessary to change the
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coordinates after boreholes or wells have been created the Assign Local Coordinates  function should
be used. 

The following information can be specified on this tab:

Local Units: Select either feet or meters. These can only be changed when the project is created.

X-Coordinate: This is the x-coordinate of the boundary point.

Y-Coordinate: This is the y-coordinate of the boundary point.

On the right side of the tab there are buttons to add and delete points. 

137
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4.1.1.4 Category Tab

Highlight the category or subcategory to assign the project to on the project tree.

4.1.2 Locating a Project

Georeferenced projects can be located on the basemap by clicking on the project in the sidebar and then
selecting Popup > Locate. The basemap will then be zoomed in so that the project can easily be
identified.

4.1.3 Opening a Project

Projects can either be opened by selecting them from a list or selecting them on the sidebar.

Selecting from the Sidebar
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To select the project from the sidebar either click on it once and then select Popup > Open or double-
click on the project on the sidebar.

Selecting from a List

To select the project from a list either select File > Open > Project or click on the Open button on the
main toolbar and select Project. The Open Project form below will then be displayed.

On the left of this form are lists of the most recently opened projects and of all the projects. On the right
side of the form the details of the highlighted project are shown, some of these details are not shown for
the most recent projects. At the top of the form is a toolbar that can be used to find a project by
specifying the project number. To select a project to open, highlight it and then click on the Open button.
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4.1.4 Editing a Project

If the project is georeferenced the GIS will show the selected web map service and project boundary;
otherwise, for local projects only the project boundary is shown. The project is also used to create and
open report responses and reports.

The project information, local coordinates, category, and address can be edited by selecting Edit >
Project Information. The Project Information form will be displayed and can edited as described in
Creating a Project .

4.1.4.1 Working with Annotation

In addition to GIS data a variety of annotation can be added, edited, and deleted using the Edit menu or
Edit toolbar. 

Rectangles, polygons, polylines, and points can be placed anywhere on the project and used to show
and describe features of the project. 

4.1.4.1.1  Rectangles

Adding

Rectangles can be added to the project using either Edit > Rectangles > Add or clicking on the Add
option of the Rectangle button menu. You will then need to draw the extents of the rectangle on the map
by clicking on one corner and then while holding down the mouse button move the mouse to opposite
corner and then release the button. After this the Edit Rectangle form below will be displayed.

The following information can be specified on this form:

Label: This is an optional label for the rectangle.

118
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Fill Color: Click this button to adjust the color of the fill.

Outline Color: Click this button to adjust the color of the outline.

Outline Width: This is the width of the line used to draw the rectangle.

Fill Type: This is used to select the fill style, either solid or transparent.

Position: This is the position of the rectangle on the map.

Font: This is used to change the font used for the labels . The same font is used for all annotation
(rectangles, polygons, polylines, and points) labels.

Editing

Existing rectangles can be edited using either Edit > Rectangles > Edit or clicking on the Edit option of
the Rectangle button menu. After this the rectangle to be edited should be clicked on, the Edit
Rectangles form above will then be displayed.

Deleting

Rectangles can be deleted using either Edit > Rectangles > Delete or clicking on the Delete option of the
Rectangle button menu. After this you will need to select the rectangle to delete by clicking on it with the
mouse.

4.1.4.1.2  Polygons

Adding

Polygons can be added to the map using either Edit > Polygons > Add or clicking on the Add option of
the Polygon button menu. You will then need to draw the vertices of the polygon on the map by clicking
on them with the mouse. After this the Edit Polygon form below will be displayed.

131
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(The appearance of the form will differ slightly depending on if it is WinLoG or WinLoG RT)

The following information can be specified on this form:

Label: This is an optional label for the polygon.

Fill Color: Click this button to adjust the color of the fill.

Outline Color: Click this button to adjust the color of the outline.

Outline Width: This is the width of the line used to draw the rectangle.

Fill Type: This is used to select the fill style, either solid or transparent.

X and Y Position: This is the position of the points of the polygon.

Font: This is used to change the font used for the labels . The same font is used for all annotation
(rectangles, polygons, polylines, and points) labels.

The buttons on the right side of the form can be used to add and remove points in the polygon. 

Editing

Existing polygons can be edited using either Edit > Polygons > Edit or clicking on the Edit option of the
Polygon button menu. After this the polygon to be edited should be clicked on, the Edit Polygons form
above will then be displayed.

Deleting

131



Chapter 4 Projects 129

© 2023 GAEA Technologies Ltd.

Polygons can be deleted from the map using either Edit > Polygons > Delete or clicking on the Delete
option of the Polygon button menu. After this you will need to select the polygon to delete by clicking on
it with the mouse.

4.1.4.1.3  Polylines

Adding

Polylines can be added to the map using either Edit > Polylines > Add or clicking on the Add option of
the Polyline button menu. You will then need to draw the vertices of the polyline on the map by clicking
on them with the mouse. After this the Edit Polyline form below will be displayed.

(The appearance of the form will differ slightly depending on if it is WinLoG or WinLoG RT)

The following information can be specified on this form:

Label: This is an optional label for the polyline.

Line Style: This is the style of line used to draw the polyline.

X and Y Position: This is the position of the points of the polyline.

Font: This is used to change the font used for the labels . The same font is used for all annotation
(rectangles, polygons, polylines, and points) labels.

The buttons on the right side of the form can be used to add and remove points in the polyline. 

Editing

131
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Existing polylines can be edited using either Edit > Polylines > Edit or clicking on the Edit option of the
Polyline button menu. After this the polyline to be edited should be clicked on, the Edit Polyline form
above will then be displayed.

Deleting

Polygons can be deleted from the map using either Edit > Polylines > Delete or clicking on the Delete
option of the Polyline button menu. After this you will need to select the polyline to delete by clicking on
it with the mouse.

4.1.4.1.4  Points

Adding

Points can be added to the map using either Edit > Points > Add or clicking on the Add option of the
Points button menu. You will then need to click on the center of the point on the map. After this the Edit
Point form below will be displayed.

(The appearance of the form will differ slightly depending on if it is WinLoG or WinLoG RT)

The following information can be specified on this form:

Label: This is an optional label for the point.

Font: This is used to change the font used for the labels . The same font is used for all annotation
(rectangles, polygons, polylines, and points) labels.

Point Type: This is used to select the type of point (circle, box, cross, triangle up, triangle down,
triangle left, or triangle right).

Point Size: This is the size of the point.

Fill Color: Click this button to adjust the color of the fill.

131
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Outline Color: Click this button to adjust the color of the outline.

Position: This is the position of the point on the map.

Editing

Existing points can be edited using either Edit > Points > Edit or clicking on the Edit option of the Point
button menu. After this the point to be edited should be clicked on, the Edit Point form above will then be
displayed.

Deleting

Points can be deleted using either Edit > Points > Delete or clicking on the Delete option of the Point
button menu. After this you will need to select the point to delete by clicking on it with the mouse.

4.1.4.1.5  Label Font

The same font is used for all annotation (rectangles, polygons, polylines, and points) labels.

The following information can be specified on this form:

Label Font: Click this button to change the font for the labels.

Outline Color: Click this button to change the outline color of the font. To specify no outline set the
outline color the same as the font color.

4.1.5 Deleting a Project

An existing project can be deleting by selecting File > Delete > Project. The Delete Project form below
will be displayed.
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4.1.6 Georeferencing a Project

When projects are imported or created their spatial reference may not be known at the time of import.
Georeferencing specifies a spatial location on the basemap for the project. Georeferencing can either be
done manually or the location of the project can be located on the basemap.

To georeference a project make sure no project is open then select either Tools > Projects >
Georeference on Map or Tools > Projects > Georeference Manually. The Georeference Project form
below will be displayed where you can select the project to be georeferenced. 
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On the left of this form are lists of the most recent projects and all the projects. On the right side of the
form the details of the highlighted project are shown, some of these details are not shown for the most
recent projects. At the top of the form is a toolbar that can be used to find a project by specifying he
project number. To select a project to georeference, highlight it and then click on the Select button.

The sections below describe the different methods for georeferencing a project.

4.1.6.1 Georeferencing to a Point

If the project is to be georeferenced to a point on the map you will then need to click on the basemap at
one of the corners of the project. After this the Georeference Project form below will be displayed. 
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The following information can be specified on this form:

Corner Identified on Map: This is the corner of the project that was used to identify the location on the
basemap.

Map X: This is the X location, normally longitude, for the corner on the basemap.

Map Y: This is the Y location, normally latitude, for the corner on the basemap.

Local Project Units: This is the local units for the project. If the project has already been georeferenced
and is only being re-positioned this will not appear.

The following information can be viewed on this form:

Project Number: This is the project number.

Project Name: This is the project name.

Project Map Boundaries: These are the project's boundaries on the basemap in map and local units.
These boundaries will change as the corner identified on the map is changed.
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4.1.6.2 Georeferencing to an Area

If the project is to be georeferenced to an area on the map you will then need to click on the basemap at
one of the corners of the project and then while holding down the mouse button drag the cursor to the
opposite corner and release the button. After this the Georeference Project form below will be displayed. 

The following information can be viewed on this form:

Project Number: This is the project number.

Project Name: This is the project name.

Project Map Boundaries: These are the project's boundaries on the basemap in map units. 

4.1.6.3 Georeferencing Manually

After the project has been selected. the Georeference Project form below will be displayed. 
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The following information can be specified on this form:

Project Number: This is the project number.

Project Name: This is the project name.

Project Map Boundaries: These are the project's boundaries on the basemap in map and local units.
These boundaries will change as the corner identified on the map is changed.

Corner Identified on Map: This is the corner of the project that was used to identify the location on the
basemap.

Map X: This is the X location, normally longitude, for the corner on the basemap.

Map Y: This is the Y location, normally latitude, for the corner on the basemap.

Local Project Units: This is the local units for the project. If the project has already been georeferenced
and is only being re-positioned this will not appear.
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4.1.7 Assigning Local Coordinates

Sometimes, it may be necessary to assign these local coordinates to a project after the project has
been created or imported. To do this select Tools > Projects > Assign Local Coordinates. The select
project form below will be displayed.

Use this form to select the project and then press the Select button. The Assign Local Coordinates form
below will be displayed.
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The following information can be specified on this form:

Local Units: Select either feet or meters.

Reference Corner: Select the corner of the project to use as a reference. The x and y coordinates
below will be assigned to this corner.

X Coordinate to Corner: This is the x coordinate of the reference corner.

Y Coordinate to Corner: This is the y coordinate of the reference corner.

After the Ok button is pressed the local coordinates will be assigned to the project.

4.1.8 Editing Project Categories

The project categories and subcategories on the project tree in the sidebar can be edited by selecting
Tools > Projects > Edit Project Tree. The Edit Project Tree Categories form will be displayed. This form
displays the project categories and subcategories in tree consisting of nodes and sub-nodes.
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The buttons at the top of the form can be used for the following:

Add: To add a project category, highlight the Projects node and click on the Add button then enter the
name below. To add a project subcategory, highlight the category and click on the Add button then enter
the name below.

Edit: To edit a project category or subcategory, highlight it and click on the Edit button. Then edit the
name below.

Remove: To remove a project category or subcategory, highlight it and click on the Remove button.
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4.1.9 Changing a Project Number

The project number is used to uniquely identify all objects associated with the project and should not
normally be changed. However, if it is required to be changed the menu item Edit > Change Project
Number can be used. This menu item is only available when no project is open. When selected the
Select Project form below will be displayed.

On the left of this form are lists of the most recently opened projects and of all the projects. On the right
side of the form the details of the highlighted project are shown, some of these details are not shown for
the most recent projects. At the top of the form is a toolbar that can be used to find a project by
specifying the project number. To select a project, highlight it and then click on the Select button.

Using this form select the project number to change and press select. The Enter New Project ID and
Name form will be displayed.
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This form is used to enter the unique new project number and name. After this is entered press the Ok
button to finalize the change. The existing project will then be exported to a temporary XML file, then the
XML file will be imported with the new project number and name, and finally the old project will be
deleted.
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4.2 Project Views

Project views are used to display and print the various types of project data. These views can contain a
single data element or a collection of data elements. Types of data elements that can be shown in a view
include:

· images
· project maps
· title blocks
· scale bars
· graphic objects; such as, text, bitmaps, polygons, lines, etc.

4.2.1 Creating a Project View

The project view is based upon the Project Template that is selected when the view is created. To create
a project view select File > New > Project View. The select Project Template form will be displayed. If a
default template has been specified for the project it will be highlighted in the list.
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To create the project view, select the desired template from the list. After this if the template contains
image data elements you will be prompted to select any images to show on the project view. 
 

4.2.2 Opening a Project View

Project views can either be opened from a list or from the sidebar.

Selecting from the Sidebar

To open the view from the sidebar either double-click on it in the sidebar or click on the view on the
sidebar and select Popup > Open.

Selecting from a List

To open a project view from a list either select File > Open > Project View or click on the Open button on
the main toolbar and select Project View, the Select Project View form below will be displayed.
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On the left of this form is a list of views and on the right side of the form the details of the highlighted view
are shown. To select a view to open, highlight it and then click on the Select button.

4.2.3 Editing a Project View

To edit a data element in the project view either select the Edit item from the data element button menu
or select the data element in the sidebar and select Popup > Edit. With the exception of title blocks, the
editing of data elements is limited to their display properties and is described in the Edit Data
Properties  section. The editing of title blocks is described in the section below.

Annotation on the page document can be added, edited, and deleted the same as with a project
template and is described in the section on Editing a Project Template .

4.2.3.1 Editing a Title Block

After a title block has been selected, the form below will be displayed. This form can be used to enter
any "User Specified Text" for the title block. All of the other data is automatically filled in by the program.

159
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4.2.4 Printing a Project View

The project view can be printed by selecting File > Print or pressing the Print button on the toolbar.

4.2.5 Sending a Project View to PDF

The project view can be sent to a PDF file by either clicking on the PDF button on the toolbar or
selecting File > Send to PDF.  The Export to PDF form below will be displayed.
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The following can be entered on this form:

Size: This is the page size for the PDF file, it can be selected from the list. Both metric and Imperial
page sizes can be selected as well as a custom page size specified.

Inches or Millimeters: For custom page sizes this is used to select the page units. When standard
page sizes are selected the units are selected automatically.

Width: This is the width of the page.

Height: This is the height of the page.

Orientation: The long axis of the page can either be oriented vertically (Portrait) or horizontally
(Landscape).

File Name: This is used to specify the name of the PDF file. The name and directory can be browsed to
using the button on the right.

Open PDF after creation: If this is checked the PDF file will be opened after it has been created.

4.2.6 Saving a Project View

After you are done editing a project view it can be saved either by selecting File > Save or by clicking on
the Save button.

The project view can also be saved with a different name either by selecting File > SaveAs or by clicking
on the SaveAs button.
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4.2.7 Deleting a Project View

To delete a project view select File > Delete > Project View, the Select Project View to Delete form
below will be displayed. 

On the left of this form is a list of views and on the right side of the form the details of the highlighted view
are shown. To select a view to display, highlight it and then click on the Select button.

4.2.8 Importing a Project View

Project views can be imported into the project by selecting File > Import > Project View. The Open form
below will be displayed.
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This form is used to select the INI file to import. After the file has been imported it will be stored with the
project and be displayed on the project's sidebar.

4.2.9 Exporting a Project View

To export a project view it must be opened. After it has been opened select File > Export > Project View.
The Export Project View form below will be displayed.

The following can be entered on this form:

File Type: This is used to select the type of file format to export. It can be a bitmap file, an INI exchange
file, or a JPEG file.
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File Name: This is used to specify the name of the file. The name and directory can be browsed to
using the button on the right.

Image Options: This area is not displayed if the file type is INI.

Resolution: This is the resolution in DPI.

Width: This is the image width in pixels.

Height: This is the image height in pixels.
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4.3 Project Templates

Project Template are used to store common layouts for project views. These templates can be created
and edited by the user. They specify the positions and display properties of data elements (objects) on
the page. The templates do not show or store any of the actual data from the application. When a project
view is created the data to be displayed will be determined by the template.

4.3.1 Creating a Project Template

To create a new template make sure no project is opened and either select File > New > Project
Template or Project Template from the New button menu. After this the New Project Template form
below will be displayed. This form has two tabs, on the first tab you can specify the information for the
new template and the second tab lists the templates currently in the application.

The following information can be specified on the New Template tab:

Name: This is the unique name of the template.

Version: This is the version number of the template.
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Paper Size: This is the size of paper for the template to use when it is printed.

Page Units: This is the units for the page, either Imperial or Metric.

Portrait or Landscape: This selects whether the page should be oriented portrait or landscape.

After the above information has been specified, click the Ok button to display and edit the project
template.

4.3.2 Opening a Project Template

An existing project template can be opened by either selecting File > Open > Project Template or
Project Template from the Open button menu. The Open Project Template form below will then be
displayed. Using this form, select the template you wish to open from the list on the left. When you click
on a template on the left, detailed information for the template will be displayed on the right.
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4.3.3 Editing a Project Template

After a project template has been created or opened it can be edited. The page layout screen will contain
a sidebar, main display area and several toolbars. On the sidebar the existing data elements on the
template are displayed. Additional data elements can be added using the data element toolbar. 

4.3.3.1 Adding Data Elements
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Data elements can be added by clicking on the Add menu item of the data element button on the toolbar
or selecting Edit > Add > data element type and then clicking on the position of the element on the
template as described in the sections below.

4.3.3.1.1  Title Blocks

Title blocks are used to show a block of text describing the map. To add a title block to the template
click on the Add item of the Title Block button menu and then click on one corner of the element on the
template and while holding down the left mouse button drag the cursor to the opposite corner. After this
the Title Block can be edited as described in the Edit Title Block  section. 

4.3.3.1.2  Project Map

This element displays the project map in a rectangle. It will display the various layers contained in the
project. To add a project map to the template click on the Add item of the Project Map button menu and
then click on one corner of the element on the template and while holding down the left mouse button
drag the cursor to the opposite corner. After this the Project Map can be edited as described in the
Project Map  section. 

4.3.3.1.3  Map Scalebar

A scalebar is used to display the scale of the project map. To add a scalebar to the template click on
the Add item of the Scalebar button menu and then click on one corner of the element on the template
and while holding down the left mouse button drag the cursor to the opposite corner.  After this the
scalebar properties can be edited as described in the Edit Scalebar  section. 

4.3.3.1.4  Images

To add an image to the template click on the Add item of the Image button and then click on one corner
of the element on the template and while holding down the left mouse button drag the cursor to the
opposite corner. After this the Display Properties form will be displayed where the properties can be
edited as described in the Edit Display Properties  section. The image to be displayed is selected
when creating the actual project view.

4.3.3.1.5  Rectangles

To add a rectangle to the template click on the Add item of the Rectangle button menu and then click on
one corner of the rectangle on the template and while holding down the left mouse button drag the cursor
to the opposite corner. After the rectangle has been added it can be edited by clicking on the Select
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button and then double-clicking on the rectangle. For a full description on how to edit a rectangle see the
section on Editing Rectangles .

4.3.3.1.6  Polygons

To add a polygon to the template click on the Add item of  the Polygon button menu and then click on
each vertex of the polygon on the template and on the last vertex double click the mouse button. After
the polygon has been added, the Polygon form will be displayed where it can be edited as described in
the Edit Polygon  section

4.3.3.1.7  Polylines

Polylines are used to show a series of joined line segments on a template. To add a polyline to the
template click on the Add item of the Polyline button menu and then click on each vertex of the polyline
on the template and on the last vertex double click the mouse button. After the polyline has been added,
the Polyline form will be displayed where it can be edited as described in the Edit Polylines  section.

4.3.3.1.8  Circles

To add a circle to the template click on the Add item of the Circle button menu and then click on the
center of the circle and while holding down the left mouse button drag the cursor to the outside of the
circle. After the circle has been added it can be edited by clicking on the Select button and then double-
clicking on the circle. For a full description on how to edit a circle see the section on Editing Circles .

4.3.3.1.9  Bitmaps

To add a bitmap to the template click on the Add item of the Bitmap button and then click on one corner
of the element on the template and while holding down the left mouse button drag the cursor to the
opposite corner. After this the Picture Properties form will be displayed and can be edited as described
in the Edit Bitmaps  section.

4.3.3.1.10  Text

Text elements are used to add annotation to the template. To add text to the template click on the Add
item of the Text button menu and  then click on one corner of the element on the template and while
holding down the left mouse button drag the cursor to the opposite corner. After the this the Text
Properties form will be displayed where the text can edited as described in the Edit Text  section.
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4.3.3.2 Editing Data Elements

After an element has been added to the template, it can be edited by clicking on the Edit item of the
button menu for the data element, double-clicking on it in the sidebar, or selecting Edit > Edit > data
element type and then selecting the element on the page with the mouse. The sections below describe
how to edit each element.

4.3.3.2.1  Title Blocks

A title block is divided into a group of boxes containing titles and data. After the title block has been
created or selected the Title Block form will be displayed.This form has three tabs for the Layout, Titles &
Data, and Interior Lines.

The following information can be entered on this tab:



Environmental - ASR156

© 2023 GAEA Technologies Ltd.

Minimum X: This is the lower boundary in page coordinates.

Maximum X: This is the upper boundary in page coordinates.

Minimum Y: This is the left boundary in page coordinates.

Maximum Y: This is the right boundary in page coordinates.

Main Title Horizontal Alignment: This is used to select the horizontal alignment of the main (first) title.

Main Data Horizontal Alignment: This is used to select the horizontal alignment of the main (first)
data.

Title Horizontal Alignment: This is used to select the horizontal alignment of the titles.

Data Horizontal Alignment: This is used to select the horizontal alignment of the data.

Title Vertical Alignment: This is used to select the vertical alignment of the titles.

Data Vertical Alignment: This is used to select the vertical alignment of the data.

Show Frame: Check to draw a box around the title block.

Frame Line Width: This is the width of the line used to draw the frame.

Frame Line Color: This is the color of the line used to draw the frame.

Frame Gap: This is the gap between the frame and the drawing portion of the title block.

Frame Rounding: This is the percentage of rounding to use at the frame corners. Zero will draw a
square corner.
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This tab is used to specify the titles and data to display in the Title Block. Titles and data can be added
and deleted using the buttons at the bottom of the tab. For each title and data the following can be
specified:

Title: This is used to specify the text to use for the title.

Title X: This is used to specify the horizontal position of the title on the template in page units.

Title Y: This is used to specify the vertical position of the title on the template in page units.

Show: Check this box to display the title in the Title Block. There is the option to use the title only for
prompting for information when the Title Block is filled in later.

Title Font: When this column is clicked on a button will appear. Click this button to select the font for
the title.

Data: This is used to select the type of data to display for this title.Several types of data can be
automatically filled in when the template is used. Alternatively, the text can be filled in at the time the
template is used by selecting "User Specified Text".

Data X: This is used to specify the horizontal position of the data on the template in page units.
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Data Y: This is used to specify the vertical position of the data on the template in page units.

Data Font: When this column is clicked on a button will appear. Click this button to select the font for
the data.

This tab is used to specify horizontal and vertical lines for the Title Block. The lines can be added and
deleted using the buttons at the top of the tab. For each line the following can be specified:

X: For vertical lines this is used to specify the horizontal position of the line on the template.

Y: For horizontal lines this is used to specify the vertical position of the line on the template.

Start: This is used to specify the start of the line. For horizontal lines they can either be started on the
left side of the Title Block or the position of the start can be specified numerically.And for vertical lines
they can either be started on the top side of the Title Block or the position of the start can be specified
numerically.

End: This is used to specify the end of the line. For horizontal lines they can either end at the right side
of the Title Block or the position of the end can be specified numerically.And for vertical lines they can
either end at the bottom side of the Title Block or the position of the end can be specified numerically.
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Width: This is used to specify the width of the line.

Color: Click this button to select the color for the line.

4.3.3.2.2  Project Map

.After the Project Map display has been created or selected, the Display Properties form will be
displayed. This form can be edited as described in the Edit Display Properties  section.

4.3.3.2.3  Map Scalebar

After the Map Scalebar display has been created or selected, the Display Properties form will be
displayed. This form can be edited as described in the Edit Display Properties  section.

4.3.3.2.4  Images

After the image has been created or selected, the Display Properties form will be displayed. This form
can be edited as described in the Edit Display Properties  section.

4.3.3.2.5  Display Properties

The Display Properties form below is used to edit the location and frame for a variety of data elements.
This form has two tabs for Properties and Frame.
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The following information can be edited on the Properties tab:

Name: This is the name of the data element.

Associated Map/Image: If the element is a Map Scale the map or image associated with the map scale
can be selected. If the element is not a map scale this is not shown.

Preserve Aspect: Check to preserve the aspect ratio of the data element when it is added to a project
document.

Minimum X: This is the lower boundary of the display in page coordinates.

Maximum X: This is the upper boundary of the display in page coordinates.

Minimum Y: This is the left boundary of the display in page coordinates.

Maximum Y: This is the right boundary of the display in page coordinates.
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The following information can be edited on the Frame tab:

Show Frame: Check to draw a box around the data element.

Frame Line Width: This is the width of the line used to draw the frame.

Frame Line Color: This is the color of the line used to draw the frame.

Frame Gap: This is the gap between the frame and the drawing portion of the data element.

Frame Rounding: This is the percentage of rounding to use at the frame corners. Zero will draw a
square corner.

4.3.3.2.6  Rectangles

After a rectangle has been created or selected for editing the form below will be displayed.
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The following information can be displayed on this form:

Label: This is an optional label for the rectangle.

Font: Click this button to change the font for the label.

Position: This is the position of the rectangle on the map.

Fill Color: Click this button to adjust the color of the fill.

Fill Type: This is to select the fill style.

Outline Color: Click this button to adjust the color of the outline of the circle.

Outline Width: This is the thickness of the outline.

4.3.3.2.7  Polygons

After a polygon has been created or selected for editing the form below will be displayed.
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The following information can be displayed on this form:

Label: This is an optional label for the polygon.

Font: Click this button to change the font for the label.

X and Y Position: This is the position of the points of the polygon.

Fill Color: Click this button to adjust the color of the fill.

Fill Type: This is to select the fill style.

Outline Color: Click this button to adjust the color of the outline of the circle.

Outline Width: This is the thickness of the outline.

The buttons on the right side of the form can be used to add and remove points in the polygon. 

4.3.3.2.8  Polylines

After a polyline has been created or selected for editing the form below will be displayed.
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The following information can be displayed on this form:

Label: This is an optional label for the polyline.

Font: Click this button to change the font for the label.

Line Style: This is the style of line used to draw the polyline.

X and Y Position: This is the position of the points of the polyline.

The buttons on the right side of the form can be used to add and remove points in the polyline. 

4.3.3.2.9  Circles

After a circle has been created or selected for editing the form below will be displayed.
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The following information can be displayed on this form:

Label: This is an optional label for the circle.

Font: Click this button to change the font for the label.

Center X, Y and Radius: This is the position of the center of the circle and the radius.

Fill Color: Click this button to adjust the color of the fill.

Fill Type: This is to select the fill style.

Outline Color: Click this button to adjust the color of the outline of the circle.

Outline Width: This is the thickness of the outline.

4.3.3.2.10  Bitmaps

After a bitmap has been added or selected the form below will be displayed.
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The following information can be entered on this form:

File Name: This is the file name of the bitmap. Click on the button on the right to select a file.

Stretch Bitmap: Select whether to stretch the bitmap so that it fills the boundaries.

Maintain Aspect Ratio: Select whether to preserve the aspect ratio of the bitmap.

Left: This is the left boundary of the bitmap in page coordinates.

Right: This is the right boundary of the bitmap in page coordinates.

Top: This is the top boundary of the bitmap in page coordinates.

Bottom: This is the bottom boundary of the bitmap in page coordinates.

4.3.3.2.11  Text

After the text element has been created or selected the form below will be displayed.
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The following information can be edited on this form:

Text: This is the text for the paragraph. There is no limit to the length of the text. The Rich Text toolbar
at the top of the form is used to format the text. This toolbar is described below.

Left: This is the position of the left border of the paragraph in inches or millimeters from the left side of
the page. If the Paragraph button on the toolbar is used to create the paragraph, this position will be filled
in by the program. 

Right: This is the position of the right border of the paragraph in inches or millimeters from the left side of
the page. If the Paragraph button on the toolbar is used to create the paragraph, this position will be filled
in by the program.

Top: This is the position of the top border of the paragraph in inches or millimeters from the top of the
page. If the Paragraph button on the toolbar is used to create the paragraph, this position will be filled in
by the program.

Bottom: This is the position of the bottom border of the paragraph in inches or millimeters from the top of
the page. If the Paragraph button on the toolbar is used to create the paragraph, this position will be filled
in by the program.

Background Color: This is the background color of the paragraph text box. When the Background Color
button is pressed, the Color form is displayed. Using this form, a basic color can be selected or a
custom color can be specified.

Frame: Select yes to display a frame around the paragraph text.
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Frame Width: This is the line width of the frame around the paragraph text. If no frame is selected
above, this field will not be displayed.

Frame Color: This is the color of the frame to display around the paragraph text. When the Frame Color
button is pressed, the Color form is displayed. Using this form, a basic color can be selected or a
custom color can be specified. If no frame is selected above, this field will not be displayed.

Text Angle: This is the angle to rotate the text.

At the top of the Paragraph Text form is the Rich Text toolbar, this toolbar can be used to modify the font
characteristics of the text. Before selecting a speed button, the text to be modified should be selected
with the mouse.

The speed buttons of the toolbar perform the following functions:

· The Font Typeface box is used to select the name of the font to use for the selected text.
· The Font Size box is used to set the size of the font for the selected text.
· The Font Color box is used to select the color of the font for the selected text.
· The Bold button is used to toggle the bold attribute of the selected text on and off.
· The Italics button is used to toggle the italic attribute of the selected text on and off.
· The Underline button is used to toggle the underline attribute of the selected text on and off.
· The Superscript button is used to toggle the superscript attribute of the selected text on and off.
· The Subscript button is used to toggle the subscript attribute of the selected text on and off.
· The Left Justify button will left justify the selected text.
· The Center Justify button will center justify the selected text.
· The Right Justify button will right justify the selected text.
· The Select All button will select all of the text in the memo field.
· The Cut button will remove the selected text and place it in the clipboard.
· The Copy button will copy the selected text to the clipboard.
· The Paste button will paste the text in the clipboard, at the current position of the cursor in the memo

field.
· The Find button will find the specified text in the memo field.
· The Replace button will replace the specified text in the memo field.
· The Symbol button will display the Symbol form. This form is used to place a symbol at the current

cursor position in the memo field. To select a symbol use the Font box to select the font containing
the symbol and then select the desired symbol. After the desired symbol has been selected, press the
Ok button to insert it into the memo field. 

· The Spell Check button will display the Spell Checker form and will check the spelling in the memo
field.

4.3.3.3 Deleting Data Elements

After an element has been added to the template, it can be deleted by clicking on the Delete item of the
button menu for the data element or selecting Edit > Delete > data element type and then selecting the
element on the page with the mouse. 
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4.3.4 Saving a Project Template

After you are done editing a project template it can be saved either by selecting File > Save or by
clicking on the Save button.

The project template can also be saved with a different name either by selecting File > SaveAs or by
clicking on the SaveAs button.

4.3.5 Deleting a Project Template

A project template can be deleted by selecting File > Delete > Project Template, the Delete Project
Template form below will then be displayed. Using this form select the template you wish to delete from
the list on the left. When you click on a template on the left, detailed information for the template will be
displayed on the right.
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4.3.6 Importing a Project Template

No project can be open when importing and exporting project templates. Project templates are imported
from INI files. Exported project templates can be used to exchange templates between computers. To
import a project template select File > Import > Project Template. The Open form below will then be
displayed, specify or select the name of the file to import. 

4.3.7 Exporting a Project Template

No project can be open when importing and exporting project templates. Project templates are exported
to INI files. Exported project templates can be used to exchange templates between computers. To
export a project template select File > Export > Project Template. If no project template is currently
open, the Export Project Template form below will then be displayed. Select the template to export in the
list on the left side of the form and then click on the Select button. If a project template is currently open
this step is skipped.
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The Save form below will then be displayed. Specify the name of the file to save the template to and then
click on the Save button. The page template will then be saved to the file. 
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4.4 Exporting a Project

Projects can be exported to an XML Exchange file or Access database file. The sections below
describes how to export data from a project. 

4.4.1 Exporting a Project to Access Database

Before the project can be exported it must first be opened . After a project has been opened it can be
exported to a project database file by selecting File > Export > Project > To MDB. The select directory
form below will be displayed, where you can specify the directory to store the exported project
database. 

Select the directory and then press the Select button. The exported file name consists of the project ID
the letters "_PN_" and the project name with the extension ".mdb". This file name should not be

124
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changed, if it is the file will not be able to be imported. If it is necessary to change the name it is
recommended that the file be zipped and the zip file name changed.

4.4.2 Exporting a Project to XML

Before the project can be exported it must first be opened . After a project has been opened it can be
exported to an XML Exchange file by selecting File > Export > Project > To XML. The Export form below
will be displayed, where you can specify the file name of the exported project. 

124
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4.5 Importing a Project

Projects can be imported from XML Exchange files and Access database files. In addition, projects from
Pocket ESA can be imported. The importation of project files is described in the section below. When
importing a project, no project can be open at the time. 

4.5.1 Importing Access Project Databases

When importing a project, no project can be open at the time. To import a project database select File >
Import > Project > From MDB, the Import Project Database form below will be displayed. Use this form
select the project database file to be imported.

The file name consists of the project ID the text "_PN_" and the project name with the extension ".mdb". 

4.5.2 Importing  XML Projects

When importing a project, no project can be open at the time. To import a project from an XML Exchange
file select File > Import > Project > From XML, the Import Project form below will be displayed. Use this
form select the file to be imported.
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If the project number of the imported project is already in the application, a new unique project number
will need to be specified. 
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After this the project will be imported and added to the project list.

4.5.3 Importing a Pocket ESA Project

Projects that have been exported from Pocket ESA can be imported by selecting File > Import > Pocket
ESA Project. The Import Pocket ESA Project form will be displayed to select the project file with an
".mdb" extension to import. Prior to importing the Pocket ESA project any Pocket ESA
questionnaires  used by the project should be imported first. 115
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4.6 Documents

PDF documents can be imported and stored with projects and used in report responses. 

4.6.1 Opening a Document

To open a document in the project select File > Open > Document or double-click on it in the sidebar.

4.6.2 Importing a Document

To import a PDF document into a project select File > Import > Document. After selecting the file the
Save Imported Document form will be displayed.

The following can be specified on this form:

Name of Document: This is the document name to show in the project.

Version: This is the document version to show in the project.

4.6.3 Deleting a Document

To delete a document in the project select File > Delete > Document. Then select the document to be
deleted.
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4.7 Images

Images can be stored with projects and used in project views. These images can be imported, saved
street views, or saved maps. To show an image on a project view an image data element must first be
added to the project template .

4.7.1 Displaying an Image

To display an image in the project select File > Open > Image or double-click on it in the sidebar. Then
select the image to be displayed.

4.7.2 Importing an Image

To import an image into a project select File > Import > Image. After selecting the image file the Save
Imported Image form will be displayed.

153
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The following can be specified on this form:

Name of Document: This is the document (image) name to show in the project.

Version: This is the image version to show in the project.

4.7.3 Saving a Map Image

To save the map image either to the project or to a file click the Save button on the GIS toolbar. When
saving to the project, the document name and version are specified. 

The following can be specified on this form:

Name of Document: This is the document (image) name to show in the project.

Version: This is the image version to show in the project.

In addition to the map image, the map scale is also saved. This scale can then be automatically included
with the map image is used in a project view that contains both an image element and a map scale
element.

4.7.4 Saving a Streetview Image

A street view for a point on the GIS can be obtained by clicking on the down arrow of the Street View
button and selected either Google or Bing. Then click on the point on the map to display the street view
in the Street View form. Additional street views can be displayed by closing the form and clicking on
other points on the map. The street view form for Google  and Bing  are explained in Chapter 1.

To save the street view image to the project click on the Save to Project button on the street view form.
The document name and version can then be specified. 

33 35
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The following can be specified on this form:

Name of Document: This is the document (image) name to show in the project.

Version: This is the image version to show in the project.

4.7.5 Deleting an Image

To delete an image in the project, select File > Delete > Image. Then select the image to be deleted.
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Chapter 5 Report Responses

After a questionnaire has been created, report response data can be entered and reports generated. All
report responses are organized into projects. You can have an unlimited number of projects and
each project can contain an unlimited number of reports.

Before the data for a report can be entered, either a new project must be created or an existing project
opened. The created or opened project is then referred to as the current project. After the project has
been opened, a new report response can be created and existing report responses can be edited.
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5.1 Creating a Report Response

To create a new report response make sure that a project has been opened and then select the New >
Report Response from the toolbar or File > New > Report Response.The New Report Response form will
be displayed.

This form shows a list of existing report responses After the unique name has been specified click the
Create button and the Select Questionnaire form below will be displayed. 
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The questionnaire will determine the questions that can be answered for the report response. Select the
questionnaire to use then press the Select button. After the report response has been created a menu
tree will be displayed showing the sections, subsections, and questions of the questionnaire. The report
response data can then be entered as described in the sections  below.188
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5.2 Opening a Report Response

To open an existing report response, first open the project and then select File > Open > Report
Response or Open > Report Response from the toolbar. The Open Report Response form shown below
will be displayed..

After the report response has been selected a menu tree will be displayed showing the sections,
subsections, and questions of the questionnaire. The report response data can then be edited as
described in the sections  below.188
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5.3 Editing a Report Response

After a report response has been created or opened, a tree view will be displayed showing the sections,
subsections, and questions specified in the questionnaire. 

Sections in the tree view can be expanded and collapsed by double clicking on the section name. When
the section is collapsed only the section is displayed and the subsections are hidden. When the section
is expanded all of the subsections are displayed below the section. Subsections can contain one or
more questions and can be expanded or collapsed by double clicking on the subsection name. When
the subsection is collapsed only the subsection is displayed and the questions are hidden. When the
subsection is expanded all of the questions are displayed below the subsection.

The response for a question can be entered by double-clicking on the question or highlighting the
question then selecting Open from the popup menu. The  editing of a question response is described in
the section  below.

At the top of the form the progress through the questionnaire is shown as well as buttons to check the
answers  and to merge the report response with the report template  to create a Word report
document.

5.3.1 Editing a Question Response

When a question response is selected for editing the Edit Question Response form will be displayed.
This form will be displayed either with two tabs (one for the Response and one for the Report preview) or
with the Response on  the left and the Report preview on the right. The type of display is set in
Preferences .

188
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At the top of the form there are buttons for the following:
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Bullet: This is used to insert a bullet into your answer. This button is only enabled if the answer field is
an edit or memo box.

Macro: This is used  to insert a text macro into the answer for a question. This button is only enabled if
the answer field is an edit or memo box. When this button is pressed the Select Macros form will be
displayed. A text macro can be inserted by selecting the Macro Section and then the Macro.

Project View: This is used to insert a previously saved project view into the answer for the question.
This button is only enabled if the answer field is an edit or memo box. When this button is pressed you
will be asked to select the project view to insert.

Image: This is used to insert an image from the project into the answer for the question. This button is
only enabled if the answer field is an edit or memo box. When this button is pressed you will be asked to
select the image to insert.

Picture: This is used to insert a picture into the answer for a question. This button is only enabled if the
answer field is an edit or memo box. When this button is pressed a file dialog form will be displayed to
select the picture file. Picture files can be "png", "jpg", "jpeg", "bmp", "emf", "wmf", "gif", or "tiff".

File: This is used to insert a file into the answer for a question. This button is only enabled if the answer
field is an edit or memo box. When this button is pressed a file dialog form will be displayed to select the
file. The files can be "txt", "xml", "html", "doc", "docx", or "pdf".

Save & Close: This is used to save the changes and close the form.

Close: This is used to close the form.

Help: This is used to display help on the form.

At the bottom of the form there are buttons that can be used for the following:

  Go to the first question (short cut key is Home)

 Go to the previous question (short cut key is Page Up)

  Go to the next question (short cut key is Page Down)

  Go to the last question (short cut key is End)

This form has two tabs for the Response  and Report  and are explained in the sections below. 

5.3.1.1 Response

The Response portion of the form is used to enter the response to a question. The possible responses
will depend on the question type for the question. Some examples are shown below.

190 191
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5.3.1.2 Report Preview

The Report portion of the form shows how a preview of the response to the question will be merged into
the report. At the top of this tab there are buttons to go to previous or next response when there are more
than one responses to a question.
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5.4 Saving a Report Response

 

To save a report response click on the Save button on the toolbar.
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5.5 Deleting a Report Response

To delete a report response open the project then select File > Delete > Report Response. The Delete
Report Response will be displayed showing a list of existing report responses in the project. Select the
report response to be deleted then press the Delete button.
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5.6 Exporting a Report Response

To export a report response to an XML exchange file, open the report response then select File > Export
> Report Response. The Export Report Response form will be displayed and is used to specify the file
name for the exported XML file.
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5.7 Importing a Report Response

To import a report response open the project then select File > Import > Report Response. The Import
Report Response form will be display where you can select the XML exchange file containing the report
response to import.
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Chapter 6 Merging Responses

After the report response data has been entered it can be merged with the report template to create the
final report. During the merging process the keywords in the report template are replaced by the text
associated with each of the answers to the
questionnaire questions.

When the merging is complete a final report will be created in Microsoft Word format. This report can
then be edited in Word to include any additional information or formatting.
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6.1 Checking Report Responses

 

Prior to merging the report responses, they should be checked to ensure that all of the questions in the
questionnaire have been answered. To check the report responses click on the Check button on the
toolbar. The Unanswered Questions form will be displayed showing any unanswered questions.
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6.2 Merging Report Responses

 

To merge a report response and create a final report, open the report response then click on the Merge
button on the toolbar. The Merge Report Responses form will be displayed. This form has two tabs, the
second tab shows a list of existing reports in the project.

The following can be specified on the first tab of this form:

Output Questionnaires and Responses Only: When this box is checked, the answers to the report
responses will only be merged with the questions and not with the report template. This will produce a
Word document that shows the questionnaire used and its answers. The resulting document can then be
included as an appendix in the report or saved as a record of the report response data collection.

Questionnaire Section and Subsection Numbering: This is used to select whether the sections and
subsections of the questionnaire are numbered in the merged report.
 
Merged Report Name: This is the unique name of the merged report. To make it easier to specify a
unique name a list of existing merged reports is shown on the Existing Reports tab.

After the name has been specified, click on the Merge button to create the final report. When the merge
process is complete the report will be opened in Word and will be added to the Reports section on the
sidebar of the project.
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6.3 Opening Reports

After a report response has been merged to create a report, the report will be added to the Reports
section on the sidebar or the Project. To open one of these reports in Word  double-click on it or highlight
it and select File > Open > Report. The Open Report form will be displayed.

Select the report and then press Open to open it in Microsoft Word.
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6.4 Deleting Reports

To delete a report in a project, open the project then select File > Delete > Report. The Delete Report
form will be displayed where you can select the report to delete. When the report is deleted the Word
document will also be deleted.
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Chapter 7 Data and User Management

This application provides functionality for both data and user management. In addition, it also provides for
data security. The application can be used either as a standalone program or in a network configuration.
When used in a network configuration, the network license manager handles the licensing and user
administration. 
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7.1 Security and User Administration

This application has several features to assist in the administration of users and to provide data security. 

7.1.1 User Administration

When the application is started users (both local and network) must login to the application. When users
are setup in the application they are assigned a username, password, and user type (privilege). Different
privilege levels are used to control access to functions of the program and data. The different user types
are administrator, power user, limited user, and guest. The functionality of different privilege levels is
described in the User Privilege Level Functionality  section below. 

If it is a network version, the user must login as a network user that is setup in the Network License
Manager program . If it is a local single user computer version of the application, local users can be
setup by the administrator by going to Tools > Manage Local Users.The Manage Users form will be
displayed showing the current local users

At the top of this form there are buttons to Add, Edit or Remove a user. 

208
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7.1.1.1 Adding a Local User

To add a local user click on the Add button at the top of the Manage Users form, the Add User form
below will be displayed. This form is used to enter the user name, password, and user type for the
account. The user name should be unique for each user. 

7.1.1.2 Editing a Local User

To edit a local user select the user in the list and click on the Edit button at the top of the Manage Users
form, the Edit User form below will be displayed. This form is used to edit the user name, password, and
user type for the account. The user name should be unique for each user. 

7.1.1.3 Removing a Local User

After a local user has been created it can be removed by selecting it on the Manager Users form and
clicking on the Remove button.
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7.1.1.4 User Privilege Level Functionality

The features and functionality that can be assessed in the application is controlled by the privilege level
of the user. In the sections below an "x" beneath a privilege level indicates that this functionality is
granted for that level. 

Admin Power Limited Guest

Main Features

Manage Users x

Manage Licenses x

View Connection Log x

Restore Main Database x

Restore Project Database x

Preferences (limited individually) x x x

Edit Macros x x

Export and Import Macros x x

Import Pocket ESA Macros x x

Project Features

Edit Project Tree x x

New Project x x x

Open Project x x x x

Edit Project Information x x x

Delete Project x x

New Project Template x x

Open Project Template x x x x

Delete Project Template x x

Print Project Preview x x x x

Assign Local Project Coordinates x x x

Import XML Project x x

Import Project Database x x

Import Project Template x x x

Export XML Project x x

Export Project Database x x

Export Project Template x x x

Questionnaire Features

Create, Edit & Delete  Question Types x x

Export and Import Question Types x x

Create, Edit & Delete Questionnaires x x

Export and Import Questionnaires x x

Import Pocket ESA Questionnaire x x

Report Template Features
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Create, Edit & Delete Report Templates x x

Import Report Template x x

Report Features

Create, Edit & Delete Report Responses x x x

Export and Import Report Responses x x x

Open Reports x x x x

7.1.2 Project Security

To provide data security to some projects a password can be added specifically for that project. This
password must then be entered every time the project is opened. To add a password when creating a
new project , check the box for Set Password and enter the Password on the New Project form.118
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To add or change a password for an existing project, open the project  and select Edit > Project
Information to display the Project Information form. Then check the box for Set Password and enter the
Password 

124
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7.2 Database Management

The data in this application is stored in a main database and project databases. These databases are
backed up at regular intervals and if necessary can be restored from backup copies. 

7.2.1 Backing up a database

The main database and current project database are backed up at regular intervals. These intervals are
set in the preferences for the program.  A project database will only be backed up if the project is
currently open.

7.2.2 Restoring a database

If necessary due to data corruption or some other problem, a database can be restored from a backup.
The sections below describe how to restore the main database and project databases. 

7.2.2.1 Restoring the Main Database

To restore the main database, select Tools > Databases > Restore > Main Database and the Select
Backup Database form below will be displayed. 

This form lists the backups by date and time. Select the database to restore from the list and then click
on the Ok button. If you choose to proceed with the restoration, the main database will be replaced by
the backup and the application will be restarted.

50
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7.2.2.2 Restoring a project database

To restore a project database, select Tools > Databases > Restore > Project Database and the Select
Project form below will be displayed. To backup a project database, no project can be currently open.

This form lists the projects in the application. Select the project to restore from a backup and then press
the Select button. The Select Backup Database form below will be displayed. 
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This form lists the backups by date and time. Select the database to restore from the list and then click
on the Ok button. 
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7.3 Network License Management

The application can be licensed on individual computers, a network, or a combination of both. When
licensed on a network the licensing is based on concurrent usage, where the number of concurrent users
must be less than or equal to the maximum number of users licensed. This means that the program can
be installed on any number of computers in the office but only the licensed number of concurrent users
can use it at the same time.

The sections below describe the installation for both the server and client computers and how to manage
the network using the License Manager.

7.3.1 Installation

When the application is managed on a network the databases and datastore for the application are also
normally stored on the network server. There are two ways to install the databases and datastore on the
server. The easiest method is to install the  application on the server and select the location of the
database and datastore directories when the application is first run on the server. Alternatively, if you
prefer not to have the application on the server you can install it on a client computer and set the
database and datastore directories to the server when the application is first run on the client.

After the databases and datastore have been installed on the server it is important not to overwrite them
each time the application is installed on a client computer. To do this make sure you answer "No" to the
last question about installing the databases and datastore when the program is first run on a client
computer. Instead database and datastore directories should be set to the server when the application is
first run.

It is important to make sure that the directories on the server where the databases and
datastore are located are shared and have their file access permissions set to "Full Control" for
all users.

7.3.1.1 Server Installation

To get the network up and running, the network license service and network license monitor program first
need to be installed on the server. The program can downloaded from GAEA's website at:

http:\\www.gaeatech.com\public\EASR2_License_Manager_Setup.exe

The following steps occur during the installation:

· The Network License Monitor program is installed on your computer
· The Network License Manager service is installed.
· Shortcuts are placed on your Programs menu

7.3.1.1.1  Starting the Service

After the network service has been installed on the server it needs to be started before it can be used.
This is done automatically when the server is restarted or it can be done manually through the Windows
Services Manager. To do it manually open the Services list from Administrative tools in the Windows
Control Panel. Select the E-ASR License Manager in the Services list and then select Start.
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7.3.1.1.2  Uninstalling the Service

To uninstall the network service automatically, select Uninstall Network License Service from the
application shortcuts on the Programs menu. The service will then be uninstalled the next time the server
is restarted. To uninstall the service immediately, it needs to be stopped first and then uninstalled. 

To stop the service, open the Services list from Administrative tools in the Windows Control Panel.
Select the E-ASR License Manager in the Services list and then select Stop. Then uninstall the network
service as described above.

7.3.1.2 Client Installation

The installation of the application on a client is the same as the single user installation. The only
difference from the single user installation is that the network option should be selected during the first-
run setup stage of the program. In addition, after the databases and datastore have been installed on the
server it is important not to overwrite them each time the application is installed on a client computer. To
do this make sure you use the default database and datastore directories (on the local C drive) during
program installation. 

7.3.1.2.1  Setting the Database and Datastore Folders

After the program has been installed on the client, the database and datastore folders need to be set to
the server. To do this run the program and log in as an administrator (this option is not available to non-
administrator users). Select File > Preferences and go to the Datasources tab. On this tab set the folder
paths for the database and datastore to the ones on the server.
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7.3.1.2.2  Setting Netw ork Options

If the network option was not selected during the installation on the client computer, then it can be set in
the preferences for the application. Select File > Preferences, and select the Network License tab on the
left.
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To get the licenses from the network, set Networked to yes and enter the network name or IP address.
The port number. should always be 3001 for the network.This information is displayed on the Network
Monitor form on the network. In the box below the network settings select the licenses to request
from the network.

7.3.2 License Manager

The licensing of the application on a network is handled through a service called ASR License Manager
and an application called ASR License Monitor. The service handles the logging in of users and grants
license requests and has no user interface. The network monitor provides a user interface for
adding/removing users and managing licenses.

When the ASR License Monitor is being run as a process the program icon will be displayed in the
system tray. A popup menu can be displayed by right clicking on the program icon in the system tray.
This menu can be used to display the network monitor form, manage licenses, manage users, show the
network log, and shutdown the network monitor. Shutting down the network license manager will stop the
network license manager process but will not stop the network service.

214
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To display the network license monitor form double-click on the icon or select it from the popup menu. 

On the right side of the Network License Monitor form a list of users that are currently logged into the
program is displayed. And on the left side is a box displaying the network server name and port. These
network properties are the ones required to be entered into the preferences of the application on client
computers, as described in the section on setting client network options . The port should always be
3001.

Below the Network Properties box are buttons for managing licenses, managing users, showing the
network log, and adjusting settings. These buttons are described in the sections below. The close button
will hide the monitor and put an icon in the system tray and the shutdown button will shutdown the
monitor.

7.3.2.1 Manage Licenses

To use the application on client computers it must be licensed on the network. The application will run in
demo mode on the client computers until the network is licensed. To manage the licenses for the
application click on the Manage Licenses button on the License Monitor form, the License Manager form
will be displayed.
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On the left side of the form is a list showing the licensing of the application. If the application is licensed
the Licensed box will be checked and the maximum number of users will be displayed. When the
application is selected the details for the license will be displayed in the box on the right side of the form.

At the top of the form there are buttons to register (unlock), export serial numbers, import unlock codes
and update the maximum users. If the application has not been licensed the Register, Export and Import
buttons will be enabled, after the application has been licensed these buttons will be not enabled.

7.3.2.1.1  Register License

To license and unlock a module click on the Register button at the top of the License Manager form. 
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This form displays the unique serial number for the network that is based on the specific computer
hardware that it is installed on. The network and user unlock codes are based on this unique serial
number and invoice number. To obtain the unlock codes, fill in the invoice number and click on the
Obtain code button. This will take you to a form on the GAEA's web site that can be filled out and sent to
GAEA for the codes. After we receive the request we will email you back the codes. If you would prefer
to contact us directly for the codes you can email us at support@gaeatech.com.

After you receive the codes from GAEA, enter them on the form along with the invoice number and click
on the Store codes button. You must enter the correct invoice number for the codes to work.

7.3.2.1.2  Export Serial Number

Another way to license the application is to export the serial number to a file and email the file to GAEA.
We will then send you back an unlock code file that can be imported. To export the serial number select
the module and click on the Export button at the top of the License Manager form. 

mailto:support@gaeatech.com.
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The unique serial number for the module is displayed at the top of this form and can not be changed.
Enter all of the information on this form, including the invoice number. After entering an email address
and file name the Email and Export buttons will be enabled. To email GAEA the serial number file click
on the Email button. To export the serial number to a file click on the Export button, this file will then
need to be emailed to us at support@gaeatech.com. 

7.3.2.1.3  Import Unlock Codes

After the serial number file has been exported and emailed to GAEA, we will email you an unlock code
file that can be imported. To import this file, select the module on the License Manager form and click on
the Import button at the top of the form. The Import Registration form will be displayed.

mailto:support@gaeatech.com
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At the top of the Import Registration form the file with the unlock codes can be selected. After the file has
been selected the module details will be shown and the unlock codes can be stored by clicking on he
Store Codes button.

7.3.2.1.4  Update Maximum Users

After the application has been licensed, the maximum number of users can be updated by clicking on
the Update button at the top of the License Manager form. To update the maximum number of users
enter the user unlock code from GAEA and click on the Store user code button.
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7.3.2.2 Manager Users

Prior to using the application on a client computer a user must have an user account setup in the license
monitor program. This user account is used to login to the application on the client computer. When user
accounts are setup they are assigned a username, password, and user type (privilege). Different privilege
levels are used to control access to functions of the program and data. The different user types are
administrator, power user, limited user, and guest. The functionality of different privilege levels is
described in the User Privilege Level Functionality  section below.

To manage the user accounts click on the Manage Users button on the Network Monitor form. The
Manage Users form displays the current user accounts and is used to add, edit, remove, export and
import user accounts.
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7.3.2.2.1  Adding a User

To add a user account click on the Add button at the top of the Manage Users form, the Add User form
below will be displayed. This form is used to enter the user name, password, and user type for the
account. The user name should be unique for each user. 

7.3.2.2.2  Editing a User

To edit a local user select the user in the list and click on the Edit button at the top of the Manage Users
form, the Edit User form below will be displayed. This form is used to edit the user name, password, and
user type for the account. The user name should be unique for each user. 
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7.3.2.2.3  Removing a User

After a user account has been created it can be removed by selecting it on the Manager Users form and
clicking on the Remove button.

7.3.2.2.4  Export User Accounts

When the licensing is being moved between servers the user accounts can be transferred by exporting
them to a file on the original server and then importing this file on the new server. To export the user
accounts click on the Export button at the top of the Manage Users form. You will then be prompted to
specify the name of the user data file.

7.3.2.2.5  Import User Accounts

After the user accounts have been exported to a user data file, this file can be imported on the new
server by clicking on the Import button at the top of the Manage Users form. 

7.3.2.3 Active Locks

The licenses that are currently being used can be shown by clicking on the Active Locks button on the
License Monitor form. The Active Locks form will display the license (lock name), owner (user), location
(IP address) and the date and time the license was granted.
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7.3.2.4 Show Log

To show a log of network license events click on the Show Log button the License Monitor form, the
Event Viewer form will be displayed. 

The details for an event can be displayed by double-clicking on the event in the list. A log file in XML
format can be created containing the events by clicking on the Save button at the top of the form. The
events in the list can be removed by clicking on the Clear button at the top of the form.

7.3.2.4.1  Display Event Details

When an event on the Event Viewer form is double-clicked, the details of the event will be displayed in
the Event Details form.
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7.3.2.5 Settings

The network server name and port can be adjusted by clicking on the Settings button on the License
Monitor form. The Network Settings form below will be displayed. The port should be set to 3001, it is not
recommended to adjust this setting without first discussing it with GAEA.
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